1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-applets/gnome-applets-2.26.3.ebuild,v 1.1 2009/07/19 21:38:23 eva Exp $
5 inherit autotools eutils gnome2 python
7 DESCRIPTION="Applets for the GNOME Desktop and Panel"
8 HOMEPAGE="http://www.gnome.org/"
10 LICENSE="GPL-2 FDL-1.1 LGPL-2"
12 KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
13 IUSE="acpi apm doc gnome gstreamer hal ipv6 networkmanager policykit"
15 # TODO: configure says python stuff is optional
16 # my secret script says cpufrequtils might be needed in RDEPEND
18 RDEPEND=">=x11-libs/gtk+-2.13
19 >=dev-libs/glib-2.18.0
20 >=gnome-base/gconf-2.8
21 >=gnome-base/gnome-panel-2.13.4
22 >=x11-libs/libxklavier-4.0
23 >=x11-libs/libwnck-2.9.3
24 >=gnome-base/gnome-desktop-2.11.1
25 >=x11-libs/libnotify-0.3.2
27 >=dev-libs/dbus-glib-0.74
28 >=dev-libs/libxml2-2.5.0
29 >=x11-themes/gnome-icon-theme-2.15.91
30 >=dev-libs/libgweather-2.22.1
34 apm? ( sys-apps/apmd )
36 >=gnome-base/libgnomekbd-2.21.4.1
37 gnome-base/gnome-settings-daemon
39 >=gnome-extra/gucharmap-2.23
40 >=gnome-base/libgtop-2.11.92
42 >=dev-python/pygobject-2.6
43 >=dev-python/pygtk-2.6
44 >=dev-python/libgnome-python-2.10
45 >=dev-python/gconf-python-2.10
46 >=dev-python/gnome-applets-python-2.10 )
48 >=media-libs/gstreamer-0.10.2
49 >=media-libs/gst-plugins-base-0.10.14
51 >=media-plugins/gst-plugins-alsa-0.10.14
52 >=media-plugins/gst-plugins-oss-0.10.14 ) )
53 hal? ( >=sys-apps/hal-0.5.3 )
54 networkmanager? ( >=net-misc/networkmanager-0.7.0 )
55 policykit? ( >=sys-auth/polkit-0.91 )"
58 >=app-text/scrollkeeper-0.1.4
59 >=app-text/gnome-doc-utils-0.3.2
60 >=dev-util/pkgconfig-0.19
61 >=dev-util/intltool-0.35
63 ~app-text/docbook-xml-dtd-4.3
64 doc? ( app-text/docbook-sgml-utils )"
66 DOCS="AUTHORS ChangeLog NEWS README"
71 # disable pyc compiling
72 mv py-compile py-compile.orig
73 ln -s $(type -P true) py-compile
75 # Make it libtool-1 compatible, bug #266248
76 rm -v m4/lt* m4/libtool.m4 || die "removing libtool macros failed"
78 # Invest applet tests need gconf/proxy/...
79 sed 's/^TESTS.*/TESTS=/g' -i invest-applet/invest/Makefile.am \
80 invest-applet/invest/Makefile.in || die "disabling invest tests failed"
82 intltoolize --force --copy --automake || die "intltoolize failed"
88 --disable-scrollkeeper
89 --disable-schemas-install
91 $(use_enable gstreamer mixer-applet)
94 $(use_enable networkmanager)
95 $(use_enable policykit polkit)"
97 if ! use ppc && ! use apm && ! use acpi; then
98 G2CONF="${G2CONF} --disable-battstat"
101 if use ppc && ! use apm; then
102 G2CONF="${G2CONF} --disable-battstat"
107 unset DBUS_SESSION_BUS_ADDRESS
108 emake check || die "emake check failed"
114 local APPLETS="accessx-status battstat charpick cpufreq drivemount geyes
115 gkb-new gswitchit gweather invest-applet mini-commander
116 mixer modemlights multiload null_applet stickynotes trashapplet"
118 # modemlights is out because it needs system-tools-backends-1
120 for applet in ${APPLETS} ; do
123 for d in AUTHORS ChangeLog NEWS README README.themes TODO ; do
124 [ -s ${applet}/${d} ] && dodoc ${applet}/${d}
132 if use acpi && ! use hal ; then
133 elog "It is highly recommended that you install acpid if you use the"
134 elog "battstat applet to prevent any issues with other applications"
135 elog "trying to read acpi information."
138 # check for new python modules on bumps
139 python_mod_optimize $(python_get_sitedir)/invest
144 python_mod_cleanup /usr/$(get_libdir)/python*/site-packages/invest