media-video/gnome-mplayer: Add 0.9.9 snapshot
[phenriksson.git] / local-misc / media-video / gnome-mplayer / gnome-mplayer-0.9.9.ebuild
blobb97f70973d5506f8b071d182d78e43a4ce8f51f9
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/media-video/gnome-mplayer/gnome-mplayer-0.9.8.ebuild,v 1.4 2009/11/08 16:50:40 klausman Exp $
5 EAPI=2
6 GCONF_DEBUG=no
7 inherit gnome2
9 DESCRIPTION="MPlayer GUI for GNOME Desktop Environment"
10 HOMEPAGE="http://code.google.com/p/gnome-mplayer"
11 SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="alpha amd64 ~hppa ppc ~ppc64 ~x86 ~x86-fbsd"
16 IUSE="alsa gnome ipod libnotify musicbrainz pulseaudio"
18 RDEPEND=">=dev-libs/glib-2.14:2
19         >=x11-libs/gtk+-2.12:2
20         >=dev-libs/dbus-glib-0.70
21         media-video/mplayer[ass]
22         alsa? ( media-libs/alsa-lib )
23         gnome? ( gnome-base/gconf:2
24                 gnome-base/gvfs
25                 gnome-base/nautilus )
26         ipod? ( >=media-libs/libgpod-0.7 )
27         libnotify? ( x11-libs/libnotify )
28         musicbrainz? ( net-misc/curl
29                 media-libs/musicbrainz:3 )
30         pulseaudio? ( >=media-sound/pulseaudio-0.9.14 )"
31 DEPEND="${RDEPEND}
32         dev-util/pkgconfig
33         sys-devel/gettext"
35 pkg_setup() {
36         DOCS="ChangeLog README DOCS/keyboard_shortcuts.txt"
37         G2CONF="--disable-dependency-tracking
38                 $(use_enable gnome schemas-install)
39                 $(use_enable gnome nautilus)
40                 --with-gio
41                 $(use_with gnome gconf)
42                 $(use_with alsa)
43                 $(use_with libnotify)
44                 $(use_with ipod libgpod)
45                 $(use_with musicbrainz libmusicbrainz3)
46                 $(use_with pulseaudio flat-volume)
47                 --without-gpm-new-method
48                 --without-gpm-old-method"
51 src_install() {
52         gnome2_src_install
53         rm -rf "${D}"/usr/share/doc/${PN}
54         rmdir -p "${D}"/var/lib # rm empty dir from destdir