Pull in patch that properly includes stdint.h
[pkg-k5-afs_openafs.git] / debian / patches / 0007-vol-add-missing-include-of-stdint.h-to-volinodes.h.patch
blob727023e15e216fae711de96f6b4ee2b2e71807b9
1 From: =?utf-8?q?Michael_La=C3=9F?= <lass@mail.uni-paderborn.de>
2 Date: Tue, 12 Sep 2017 19:33:15 +0200
3 Subject: vol: add missing include of stdint.h to volinodes.h
5 volinodes.h requires stdint.h for use of uintptr_t:
7 In file included from vutil.c:55:0:
8 volinodes.h: In function 'init_inode_info':
9 volinodes.h:109:45: error: 'uintptr_t' undeclared (first use in this function); did you mean 'intptr_t'?
10 stuff[i].inode = (Inode*)((char*)header + (uintptr_t)stuff[i].inode);
11 ^~~~~~~~~
12 intptr_t
14 Similar changes have been applied earlier in 1e53da3.
16 This change does not apply to master since e2b4fde added an include of roken.h
17 to all affected source files which in turn includes stdint.h.
19 Change-Id: Iddd174e844583e06f66d910052e11feff928ba40
20 ---
21 src/vol/volinodes.h | 3 +++
22 1 file changed, 3 insertions(+)
24 diff --git a/src/vol/volinodes.h b/src/vol/volinodes.h
25 index 181b441..2dec0ce 100644
26 --- a/src/vol/volinodes.h
27 +++ b/src/vol/volinodes.h
28 @@ -18,6 +18,9 @@
29 #define __volinodes_h_
31 #include <stddef.h>
32 +#ifdef HAVE_STDINT_H
33 +# include <stdint.h>
34 +#endif
36 /* Used by vutil.c and salvager.c */