Do ioctl(file, BLKRRPART) if supported to reread partitions when they are already...
[polld.git] / debian / rules
blobd1c696afc07e3191caa5c469a885ff90966c2cae
1 #!/usr/bin/make -f
2 # -*- makefile -*-
3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
10 #export DH_VERBOSE=1
15 CFLAGS = -Wall -g
17 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
18 CFLAGS += -O0
19 else
20 CFLAGS += -O2
21 endif
23 configure:
24 configure-stamp:
27 build: build-stamp
29 build-stamp: configure-stamp
30 dh_testdir
32 # Add here commands to compile the package.
33 $(MAKE) all CFLAGS="$(CFLAGS)"
35 clean:
36 dh_testdir
37 dh_testroot
39 # Add here commands to clean up after the build process.
40 -$(MAKE) clean
42 dh_clean
44 install: build
45 dh_testdir
46 dh_testroot
47 dh_clean -k
48 dh_installdirs
50 # Add here commands to install the package into debian/polld.
51 $(MAKE) install DESTDIR=$(CURDIR)/debian/polld
54 # Build architecture-independent files here.
55 binary-indep: build install
56 # We have nothing to do by default.
58 # Build architecture-dependent files here.
59 binary-arch: build install
60 dh_testdir
61 dh_testroot
62 dh_installchangelogs
63 dh_installdocs
64 dh_installinit
65 dh_link
66 dh_strip
67 dh_compress
68 dh_fixperms
69 dh_installdeb
70 dh_shlibdeps
71 dh_gencontrol
72 dh_md5sums
73 dh_builddeb
75 binary: binary-indep binary-arch
76 .PHONY: build clean binary-indep binary-arch binary install configure