3 # Sample debian/rules that uses debhelper.
4 # This file was originally written by Joey Hess and Craig Small.
5 # As a special exception, when this file is copied by dh-make into a
6 # dh-make output file, you may use that output file without restriction.
7 # This special exception was added by Craig Small in version 0.37 of dh-make.
9 # Uncomment this to turn on verbose mode.
17 ifneq (,$(findstring noopt
,$(DEB_BUILD_OPTIONS
)))
29 build-stamp
: configure-stamp
32 # Add here commands to compile the package.
33 $(MAKE
) all CFLAGS
="$(CFLAGS)"
39 # Add here commands to clean up after the build process.
50 # Add here commands to install the package into debian/polld.
51 $(MAKE
) install DESTDIR
=$(CURDIR
)/debian
/polld
54 # Build architecture-independent files here.
55 binary-indep
: build
install
56 # We have nothing to do by default.
58 # Build architecture-dependent files here.
59 binary-arch
: build
install
75 binary
: binary-indep binary-arch
76 .PHONY
: build
clean binary-indep binary-arch binary
install configure