1 From 821b6e565433da3132e6a4c69b8ce57912427f35 Mon Sep 17 00:00:00 2001
2 From: Wolfgang Bumiller <w.bumiller@proxmox.com>
3 Date: Mon, 1 Aug 2016 10:52:46 +0200
4 Subject: [PATCH 40/47] enable cache=unsafe for vma extract_content and
7 We don't send any flush here, so we need to open with cache=unsafe.
9 Signed-off-by: Alexandre Derumier <aderumier@odiso.com>
13 2 files changed, 2 insertions(+), 2 deletions(-)
15 diff --git a/savevm-async.c b/savevm-async.c
16 index 6ac03af..46c1be7 100644
19 @@ -253,7 +253,7 @@ void qmp_savevm_start(bool has_statefile, const char *statefile, Error **errp)
21 Error *local_err = NULL;
23 - int bdrv_oflags = BDRV_O_RDWR | BDRV_O_RESIZE;
24 + int bdrv_oflags = BDRV_O_RDWR | BDRV_O_RESIZE | BDRV_O_NO_FLUSH;
27 if (snap_state.state != SAVE_STATE_DONE) {
28 diff --git a/vma.c b/vma.c
29 index aafdc2d..4f55799 100644
32 @@ -281,7 +281,7 @@ static int extract_content(int argc, char **argv)
35 const char *format = NULL;
36 - int flags = BDRV_O_RDWR;
37 + int flags = BDRV_O_RDWR | BDRV_O_NO_FLUSH;
38 bool write_zero = true;