1 From: Izik Eidus <ieidus@redhat.com>
2 Date: Thu, 8 Oct 2009 14:39:39 +0000 (+0200)
4 X-Git-Url: http://git.kernel.org/?p=virt%2Fkvm%2Fqemu-kvm.git;a=commitdiff_plain;h=ccb167e9d7d460a7cd09fdabd848efd3606dd27e
8 patch is slighly modified by <support@proxmox.com> for old libc
10 Call MADV_MERGEABLE on guest memory allocations. MADV_MERGABLE will be
11 available starting in Linux 2.6.32. This system call registers a region of
12 virtual address space with Linux as a candidate for transparent memory
16 Signed-off-by: Izik Eidus <ieidus@redhat.com>
17 Signed-off-by: Anthony Liguori <aliguori@us.ibm.com>
20 Index: qemu-kvm/exec.c
21 ===================================================================
22 --- qemu-kvm.orig/exec.c 2009-12-21 10:37:57.000000000 +0100
23 +++ qemu-kvm/exec.c 2009-12-21 11:22:34.000000000 +0100
28 +/* our libc does not define it */
29 +#define MADV_MERGEABLE 12
31 //#define DEBUG_TB_INVALIDATE