1 From 46fd4bb673a91d40352c95e9d3f62f63b5021053 Mon Sep 17 00:00:00 2001
2 From: Stefan Priebe <s.priebe@profihost.ag>
3 Date: Fri, 29 Nov 2013 22:17:03 +0100
4 Subject: [PATCH] internal-snapshot-async-qemu1.7.patch
9 hmp-commands.hx | 34 ++++
12 include/block/block.h | 1 +
13 include/sysemu/sysemu.h | 5 +-
15 qapi-schema.json | 46 +++++
16 qemu-options.hx | 13 ++
17 qmp-commands.hx | 31 +++
18 savevm-async.c | 478 +++++++++++++++++++++++++++++++++++++++++++++++
21 14 files changed, 692 insertions(+), 7 deletions(-)
22 create mode 100644 savevm-async.c
24 Index: new/Makefile.objs
25 ===================================================================
26 --- new.orig/Makefile.objs 2014-11-20 09:13:01.000000000 +0100
27 +++ new/Makefile.objs 2014-11-20 09:16:47.000000000 +0100
29 common-obj-y += qemu-char.o #aio.o
30 common-obj-y += page_cache.o
31 common-obj-y += qjson.o
32 +common-obj-y += savevm-async.o
34 common-obj-$(CONFIG_SPICE) += spice-qemu-char.o
37 ===================================================================
38 --- new.orig/block.c 2014-11-20 09:13:01.000000000 +0100
39 +++ new/block.c 2014-11-20 09:16:47.000000000 +0100
41 bdrv_attach_child(bs_top, bs_new, &child_backing);
44 -static void bdrv_delete(BlockDriverState *bs)
45 +void bdrv_delete(BlockDriverState *bs)
48 assert(bdrv_op_blocker_is_empty(bs));
49 Index: new/hmp-commands.hx
50 ===================================================================
51 --- new.orig/hmp-commands.hx 2014-11-20 09:13:01.000000000 +0100
52 +++ new/hmp-commands.hx 2014-11-20 09:16:47.000000000 +0100
54 show current migration parameters
55 @item info migrate_cache_size
56 show current migration XBZRLE cache size
60 show balloon information
62 @@ -1857,3 +1859,35 @@
68 + .name = "savevm-start",
69 + .args_type = "statefile:s?",
70 + .params = "[statefile]",
71 + .help = "Prepare for snapshot and halt VM. Save VM state to statefile.",
72 + .mhandler.cmd = hmp_savevm_start,
76 + .name = "snapshot-drive",
77 + .args_type = "device:s,name:s",
78 + .params = "device name",
79 + .help = "Create internal snapshot.",
80 + .mhandler.cmd = hmp_snapshot_drive,
84 + .name = "delete-drive-snapshot",
85 + .args_type = "device:s,name:s",
86 + .params = "device name",
87 + .help = "Delete internal snapshot.",
88 + .mhandler.cmd = hmp_delete_drive_snapshot,
92 + .name = "savevm-end",
95 + .help = "Resume VM after snaphot.",
96 + .mhandler.cmd = hmp_savevm_end,
99 ===================================================================
100 --- new.orig/hmp.c 2014-11-20 09:13:01.000000000 +0100
101 +++ new/hmp.c 2014-11-20 09:16:47.000000000 +0100
102 @@ -1849,6 +1849,63 @@
104 qapi_free_MemoryDeviceInfoList(info_list);
107 +void hmp_savevm_start(Monitor *mon, const QDict *qdict)
109 + Error *errp = NULL;
110 + const char *statefile = qdict_get_try_str(qdict, "statefile");
112 + qmp_savevm_start(statefile != NULL, statefile, &errp);
113 + hmp_handle_error(mon, &errp);
116 +void hmp_snapshot_drive(Monitor *mon, const QDict *qdict)
118 + Error *errp = NULL;
119 + const char *name = qdict_get_str(qdict, "name");
120 + const char *device = qdict_get_str(qdict, "device");
122 + qmp_snapshot_drive(device, name, &errp);
123 + hmp_handle_error(mon, &errp);
126 +void hmp_delete_drive_snapshot(Monitor *mon, const QDict *qdict)
128 + Error *errp = NULL;
129 + const char *name = qdict_get_str(qdict, "name");
130 + const char *device = qdict_get_str(qdict, "device");
132 + qmp_delete_drive_snapshot(device, name, &errp);
133 + hmp_handle_error(mon, &errp);
136 +void hmp_savevm_end(Monitor *mon, const QDict *qdict)
138 + Error *errp = NULL;
140 + qmp_savevm_end(&errp);
141 + hmp_handle_error(mon, &errp);
144 +void hmp_info_savevm(Monitor *mon, const QDict *qdict)
147 + info = qmp_query_savevm(NULL);
149 + if (info->has_status) {
150 + monitor_printf(mon, "savevm status: %s\n", info->status);
151 + monitor_printf(mon, "total time: %" PRIu64 " milliseconds\n",
154 + monitor_printf(mon, "savevm status: not running\n");
156 + if (info->has_bytes) {
157 + monitor_printf(mon, "Bytes saved: %"PRIu64"\n", info->bytes);
159 + if (info->has_error) {
160 + monitor_printf(mon, "Error: %s\n", info->error);
164 void hmp_qom_list(Monitor *mon, const QDict *qdict)
167 ===================================================================
168 --- new.orig/hmp.h 2014-11-20 09:13:01.000000000 +0100
169 +++ new/hmp.h 2014-11-20 09:16:47.000000000 +0100
171 void hmp_info_uuid(Monitor *mon, const QDict *qdict);
172 void hmp_info_chardev(Monitor *mon, const QDict *qdict);
173 void hmp_info_mice(Monitor *mon, const QDict *qdict);
174 +void hmp_info_savevm(Monitor *mon, const QDict *qdict);
175 void hmp_info_migrate(Monitor *mon, const QDict *qdict);
176 void hmp_info_migrate_capabilities(Monitor *mon, const QDict *qdict);
177 void hmp_info_migrate_parameters(Monitor *mon, const QDict *qdict);
179 void hmp_netdev_del(Monitor *mon, const QDict *qdict);
180 void hmp_getfd(Monitor *mon, const QDict *qdict);
181 void hmp_closefd(Monitor *mon, const QDict *qdict);
182 +void hmp_savevm_start(Monitor *mon, const QDict *qdict);
183 +void hmp_snapshot_drive(Monitor *mon, const QDict *qdict);
184 +void hmp_delete_drive_snapshot(Monitor *mon, const QDict *qdict);
185 +void hmp_savevm_end(Monitor *mon, const QDict *qdict);
186 void hmp_sendkey(Monitor *mon, const QDict *qdict);
187 void hmp_screendump(Monitor *mon, const QDict *qdict);
188 void hmp_nbd_server_start(Monitor *mon, const QDict *qdict);
189 Index: new/include/block/block.h
190 ===================================================================
191 --- new.orig/include/block/block.h 2014-11-20 09:13:01.000000000 +0100
192 +++ new/include/block/block.h 2014-11-20 09:16:47.000000000 +0100
194 int bdrv_get_backing_file_depth(BlockDriverState *bs);
195 void bdrv_refresh_filename(BlockDriverState *bs);
196 int bdrv_truncate(BlockDriverState *bs, int64_t offset);
197 +void bdrv_delete(BlockDriverState *bs);
198 int64_t bdrv_nb_sectors(BlockDriverState *bs);
199 int64_t bdrv_getlength(BlockDriverState *bs);
200 int64_t bdrv_get_allocated_file_size(BlockDriverState *bs);
201 Index: new/include/sysemu/sysemu.h
202 ===================================================================
203 --- new.orig/include/sysemu/sysemu.h 2014-11-20 09:13:01.000000000 +0100
204 +++ new/include/sysemu/sysemu.h 2014-11-20 09:16:47.000000000 +0100
207 void hmp_savevm(Monitor *mon, const QDict *qdict);
208 int load_vmstate(const char *name);
209 +int load_state_from_blockdev(const char *filename);
210 void hmp_delvm(Monitor *mon, const QDict *qdict);
211 void hmp_info_snapshots(Monitor *mon, const QDict *qdict);
213 void qemu_announce_self(void);
215 bool qemu_savevm_state_blocked(Error **errp);
216 -void qemu_savevm_state_begin(QEMUFile *f,
217 +int qemu_savevm_state_begin(QEMUFile *f,
218 const MigrationParams *params);
219 void qemu_savevm_state_header(QEMUFile *f);
220 int qemu_savevm_state_iterate(QEMUFile *f);
221 -void qemu_savevm_state_complete(QEMUFile *f);
222 +int qemu_savevm_state_complete(QEMUFile *f);
223 void qemu_savevm_state_cancel(void);
224 uint64_t qemu_savevm_state_pending(QEMUFile *f, uint64_t max_size);
225 int qemu_loadvm_state(QEMUFile *f);
227 ===================================================================
228 --- new.orig/monitor.c 2014-11-20 09:13:01.000000000 +0100
229 +++ new/monitor.c 2014-11-20 09:16:47.000000000 +0100
230 @@ -2876,6 +2876,13 @@
231 .mhandler.cmd = hmp_info_migrate_cache_size,
237 + .help = "show savevm status",
238 + .mhandler.cmd = hmp_info_savevm,
244 Index: new/qapi-schema.json
245 ===================================================================
246 --- new.orig/qapi-schema.json 2014-11-20 09:13:01.000000000 +0100
247 +++ new/qapi-schema.json 2014-11-20 09:16:47.000000000 +0100
250 '*setup-time': 'int'} }
255 +# Information about current migration process.
257 +# @status: #optional string describing the current savevm status.
258 +# This can be 'active', 'completed', 'failed'.
259 +# If this field is not returned, no savevm process
260 +# has been initiated
262 +# @error: #optional string containing error message is status is failed.
264 +# @total-time: #optional total amount of milliseconds since savevm started.
265 +# If savevm has ended, it returns the total save time
267 +# @bytes: #optional total amount of data transfered
271 +{ 'struct': 'SaveVMInfo',
272 + 'data': {'*status': 'str', '*error': 'str',
273 + '*total-time': 'int', '*bytes': 'int'} }
278 +# Returns information about current savevm process.
280 +# Returns: @SaveVMInfo
284 +{ 'command': 'query-savevm', 'returns': 'SaveVMInfo' }
291 @@ -2649,8 +2685,18 @@
296 { 'command': 'query-target', 'returns': 'TargetInfo' }
298 +{ 'command': 'savevm-start', 'data': { '*statefile': 'str' } }
300 +{ 'command': 'snapshot-drive', 'data': { 'device': 'str', 'name': 'str' } }
302 +{ 'command': 'delete-drive-snapshot', 'data': { 'device': 'str', 'name': 'str' } }
304 +{ 'command': 'savevm-end' }
310 Index: new/qemu-options.hx
311 ===================================================================
312 --- new.orig/qemu-options.hx 2014-11-20 09:13:01.000000000 +0100
313 +++ new/qemu-options.hx 2014-11-20 09:16:47.000000000 +0100
314 @@ -2975,6 +2975,19 @@
315 Start right away with a saved state (@code{loadvm} in monitor)
318 +DEF("loadstate", HAS_ARG, QEMU_OPTION_loadstate, \
319 + "-loadstate file\n" \
320 + " start right away with a saved state\n",
323 +@item -loadstate @var{file}
325 +Start right away with a saved state. This option does not rollback
326 +disk state like @code{loadvm}, so user must make sure that disk
327 +have correct state. @var{file} can be any valid device URL. See the section
328 +for "Device URL Syntax" for more information.
332 DEF("daemonize", 0, QEMU_OPTION_daemonize, \
333 "-daemonize daemonize QEMU after initializing\n", QEMU_ARCH_ALL)
334 Index: new/qmp-commands.hx
335 ===================================================================
336 --- new.orig/qmp-commands.hx 2014-11-20 09:13:01.000000000 +0100
337 +++ new/qmp-commands.hx 2014-11-20 09:16:47.000000000 +0100
338 @@ -4200,6 +4200,36 @@
344 + .name = "savevm-start",
345 + .args_type = "statefile:s?",
346 + .mhandler.cmd_new = qmp_marshal_input_savevm_start,
350 + .name = "snapshot-drive",
351 + .args_type = "device:s,name:s",
352 + .mhandler.cmd_new = qmp_marshal_input_snapshot_drive,
356 + .name = "delete-drive-snapshot",
357 + .args_type = "device:s,name:s",
358 + .mhandler.cmd_new = qmp_marshal_input_delete_drive_snapshot,
362 + .name = "savevm-end",
364 + .mhandler.cmd_new = qmp_marshal_input_savevm_end,
368 + .name = "query-savevm",
370 + .mhandler.cmd_new = qmp_marshal_input_query_savevm,
374 .name = "query-rocker",
375 Index: new/savevm-async.c
376 ===================================================================
377 --- /dev/null 1970-01-01 00:00:00.000000000 +0000
378 +++ new/savevm-async.c 2014-11-20 09:17:48.000000000 +0100
380 +#include "qemu-common.h"
381 +#include "qapi/qmp/qerror.h"
382 +#include "qemu/error-report.h"
383 +#include "sysemu/sysemu.h"
384 +#include "qmp-commands.h"
385 +#include "qemu-options.h"
386 +#include "migration/qemu-file.h"
387 +#include "qom/qom-qobject.h"
388 +#include "migration/migration.h"
389 +#include "block/snapshot.h"
390 +#include "block/qapi.h"
391 +#include "block/block.h"
392 +#include "qemu/timer.h"
393 +#include "sysemu/block-backend.h"
395 +/* #define DEBUG_SAVEVM_STATE */
397 +#ifdef DEBUG_SAVEVM_STATE
398 +#define DPRINTF(fmt, ...) \
399 + do { printf("savevm-async: " fmt, ## __VA_ARGS__); } while (0)
401 +#define DPRINTF(fmt, ...) \
409 + SAVE_STATE_COMPLETED,
410 + SAVE_STATE_CANCELLED
414 +static struct SnapshotState {
415 + BlockDriverState *bs;
420 + int saved_vm_running;
422 + int64_t total_time;
425 +SaveVMInfo *qmp_query_savevm(Error **errp)
427 + SaveVMInfo *info = g_malloc0(sizeof(*info));
428 + struct SnapshotState *s = &snap_state;
430 + if (s->state != SAVE_STATE_DONE) {
431 + info->has_bytes = true;
432 + info->bytes = s->bs_pos;
433 + switch (s->state) {
434 + case SAVE_STATE_ERROR:
435 + info->has_status = true;
436 + info->status = g_strdup("failed");
437 + info->has_total_time = true;
438 + info->total_time = s->total_time;
440 + info->has_error = true;
441 + info->error = g_strdup(error_get_pretty(s->error));
444 + case SAVE_STATE_ACTIVE:
445 + info->has_status = true;
446 + info->status = g_strdup("active");
447 + info->has_total_time = true;
448 + info->total_time = qemu_clock_get_ms(QEMU_CLOCK_REALTIME)
451 + case SAVE_STATE_COMPLETED:
452 + info->has_status = true;
453 + info->status = g_strdup("completed");
454 + info->has_total_time = true;
455 + info->total_time = s->total_time;
463 +static int save_snapshot_cleanup(void)
467 + DPRINTF("save_snapshot_cleanup\n");
469 + snap_state.total_time = qemu_clock_get_ms(QEMU_CLOCK_REALTIME) -
470 + snap_state.total_time;
472 + if (snap_state.file) {
473 + ret = qemu_fclose(snap_state.file);
476 + if (snap_state.bs) {
477 + /* try to truncate, but ignore errors (will fail on block devices).
478 + * note: bdrv_read() need whole blocks, so we round up
480 + size_t size = (snap_state.bs_pos + BDRV_SECTOR_SIZE) & BDRV_SECTOR_MASK;
481 + bdrv_truncate(snap_state.bs, size);
482 + bdrv_op_unblock_all(snap_state.bs, snap_state.blocker);
483 + error_free(snap_state.blocker);
484 + snap_state.blocker = NULL;
485 + bdrv_unref(snap_state.bs);
486 + snap_state.bs = NULL;
492 +static void save_snapshot_error(const char *fmt, ...)
498 + msg = g_strdup_vprintf(fmt, ap);
501 + DPRINTF("save_snapshot_error: %s\n", msg);
503 + if (!snap_state.error) {
504 + error_set(&snap_state.error, ERROR_CLASS_GENERIC_ERROR, "%s", msg);
509 + snap_state.state = SAVE_STATE_ERROR;
511 + save_snapshot_cleanup();
514 +static void save_snapshot_completed(void)
516 + DPRINTF("save_snapshot_completed\n");
518 + if (save_snapshot_cleanup() < 0) {
519 + snap_state.state = SAVE_STATE_ERROR;
521 + snap_state.state = SAVE_STATE_COMPLETED;
525 +static int block_state_close(void *opaque)
527 + snap_state.file = NULL;
528 + return bdrv_flush(snap_state.bs);
531 +static int block_state_put_buffer(void *opaque, const uint8_t *buf,
532 + int64_t pos, int size)
536 + assert(pos == snap_state.bs_pos);
538 + if ((ret = bdrv_pwrite(snap_state.bs, snap_state.bs_pos, buf, size)) > 0) {
539 + snap_state.bs_pos += ret;
545 +static void process_savevm_co(void *opaque)
549 + MigrationParams params = {
554 + snap_state.state = SAVE_STATE_ACTIVE;
556 + qemu_mutex_unlock_iothread();
557 + qemu_savevm_state_header(snap_state.file);
558 + ret = qemu_savevm_state_begin(snap_state.file, ¶ms);
559 + qemu_mutex_lock_iothread();
562 + save_snapshot_error("qemu_savevm_state_begin failed");
566 + while (snap_state.state == SAVE_STATE_ACTIVE) {
567 + uint64_t pending_size;
569 + pending_size = qemu_savevm_state_pending(snap_state.file, 0);
571 + if (pending_size) {
572 + ret = qemu_savevm_state_iterate(snap_state.file);
574 + save_snapshot_error("qemu_savevm_state_iterate error %d", ret);
577 + DPRINTF("savevm inerate pending size %lu ret %d\n", pending_size, ret);
579 + DPRINTF("done iterating\n");
580 + if (runstate_is_running()) {
581 + vm_stop(RUN_STATE_SAVE_VM);
583 + DPRINTF("savevm inerate finished\n");
584 + qemu_savevm_state_complete(snap_state.file);
585 + DPRINTF("save complete\n");
586 + save_snapshot_completed();
590 + /* stop the VM if we get to the end of available space,
591 + * or if pending_size is just a few MB
593 + maxlen = bdrv_getlength(snap_state.bs) - 30*1024*1024;
594 + if ((pending_size < 100000) ||
595 + ((snap_state.bs_pos + pending_size) >= maxlen)) {
596 + if (runstate_is_running()) {
597 + vm_stop(RUN_STATE_SAVE_VM);
602 + if(snap_state.state == SAVE_STATE_CANCELLED) {
603 + save_snapshot_completed();
604 + Error *errp = NULL;
605 + qmp_savevm_end(&errp);
610 +static const QEMUFileOps block_file_ops = {
611 + .put_buffer = block_state_put_buffer,
612 + .close = block_state_close,
616 +void qmp_savevm_start(bool has_statefile, const char *statefile, Error **errp)
618 + BlockDriver *drv = NULL;
619 + Error *local_err = NULL;
621 + int bdrv_oflags = BDRV_O_CACHE_WB | BDRV_O_RDWR;
624 + if (snap_state.state != SAVE_STATE_DONE) {
625 + error_set(errp, ERROR_CLASS_GENERIC_ERROR,
626 + "VM snapshot already started\n");
630 + /* initialize snapshot info */
631 + snap_state.saved_vm_running = runstate_is_running();
632 + snap_state.bs_pos = 0;
633 + snap_state.total_time = qemu_clock_get_ms(QEMU_CLOCK_REALTIME);
634 + snap_state.blocker = NULL;
636 + if (snap_state.error) {
637 + error_free(snap_state.error);
638 + snap_state.error = NULL;
641 + if (!has_statefile) {
642 + vm_stop(RUN_STATE_SAVE_VM);
643 + snap_state.state = SAVE_STATE_COMPLETED;
647 + if (qemu_savevm_state_blocked(errp)) {
651 + /* Open the image */
652 + snap_state.bs = bdrv_new();
654 + ret = bdrv_open(&snap_state.bs, statefile, NULL, NULL, bdrv_oflags, drv, &local_err);
656 + error_set(errp, ERROR_CLASS_GENERIC_ERROR, "failed to open '%s'", statefile);
660 + snap_state.file = qemu_fopen_ops(&snap_state, &block_file_ops);
662 + if (!snap_state.file) {
663 + error_set(errp, ERROR_CLASS_GENERIC_ERROR, "failed to open '%s'", statefile);
668 + error_setg(&snap_state.blocker, "block device is in use by savevm");
669 + bdrv_op_block_all(snap_state.bs, snap_state.blocker);
671 + Coroutine *co = qemu_coroutine_create(process_savevm_co);
672 + qemu_coroutine_enter(co, NULL);
678 + save_snapshot_error("setup failed");
680 + if (snap_state.saved_vm_running) {
685 +void qmp_savevm_end(Error **errp)
687 + if (snap_state.state == SAVE_STATE_DONE) {
688 + error_set(errp, ERROR_CLASS_GENERIC_ERROR,
689 + "VM snapshot not started\n");
693 + if (snap_state.state == SAVE_STATE_ACTIVE) {
694 + snap_state.state = SAVE_STATE_CANCELLED;
698 + if (snap_state.saved_vm_running) {
702 + snap_state.state = SAVE_STATE_DONE;
705 +void qmp_snapshot_drive(const char *device, const char *name, Error **errp)
708 + BlockDriverState *bs;
709 + QEMUSnapshotInfo sn1, *sn = &sn1;
717 + if (snap_state.state != SAVE_STATE_COMPLETED) {
718 + error_set(errp, ERROR_CLASS_GENERIC_ERROR,
719 + "VM snapshot not ready/started\n");
723 + blk = blk_by_name(device);
725 + error_set(errp, ERROR_CLASS_DEVICE_NOT_FOUND,
726 + "Device '%s' not found", device);
731 + if (!bdrv_is_inserted(bs)) {
732 + error_setg(errp, QERR_DEVICE_HAS_NO_MEDIUM, device);
736 + if (bdrv_is_read_only(bs)) {
737 + error_setg(errp, "Node '%s' is read only", device);
741 + if (!bdrv_can_snapshot(bs)) {
742 + error_setg(errp, QERR_UNSUPPORTED);
746 + if (bdrv_snapshot_find(bs, sn, name) >= 0) {
747 + error_set(errp, ERROR_CLASS_GENERIC_ERROR,
748 + "snapshot '%s' already exists", name);
753 + memset(sn, 0, sizeof(*sn));
757 + sn->date_sec = tb.time;
758 + sn->date_nsec = tb.millitm * 1000000;
760 + gettimeofday(&tv, NULL);
761 + sn->date_sec = tv.tv_sec;
762 + sn->date_nsec = tv.tv_usec * 1000;
764 + sn->vm_clock_nsec = qemu_clock_get_ns(QEMU_CLOCK_VIRTUAL);
766 + pstrcpy(sn->name, sizeof(sn->name), name);
768 + sn->vm_state_size = 0; /* do not save state */
770 + ret = bdrv_snapshot_create(bs, sn);
772 + error_set(errp, ERROR_CLASS_GENERIC_ERROR,
773 + "Error while creating snapshot on '%s'\n", device);
778 +void qmp_delete_drive_snapshot(const char *device, const char *name,
782 + BlockDriverState *bs;
783 + QEMUSnapshotInfo sn1, *sn = &sn1;
784 + Error *local_err = NULL;
788 + blk = blk_by_name(device);
790 + error_set(errp, ERROR_CLASS_DEVICE_NOT_FOUND,
791 + "Device '%s' not found", device);
796 + if (bdrv_is_read_only(bs)) {
797 + error_setg(errp, "Node '%s' is read only", device);
801 + if (!bdrv_can_snapshot(bs)) {
802 + error_setg(errp, QERR_UNSUPPORTED);
806 + if (bdrv_snapshot_find(bs, sn, name) < 0) {
807 + /* return success if snapshot does not exists */
811 + ret = bdrv_snapshot_delete(bs, NULL, name, &local_err);
813 + error_set(errp, ERROR_CLASS_GENERIC_ERROR,
814 + "Error while deleting snapshot on '%s'\n", device);
819 +static int loadstate_get_buffer(void *opaque, uint8_t *buf, int64_t pos,
822 + BlockDriverState *bs = (BlockDriverState *)opaque;
823 + int64_t maxlen = bdrv_getlength(bs);
824 + if (pos > maxlen) {
827 + if ((pos + size) > maxlen) {
828 + size = maxlen - pos - 1;
833 + return bdrv_pread(bs, pos, buf, size);
836 +static const QEMUFileOps loadstate_file_ops = {
837 + .get_buffer = loadstate_get_buffer,
840 +int load_state_from_blockdev(const char *filename)
842 + BlockDriverState *bs = NULL;
843 + BlockDriver *drv = NULL;
844 + Error *local_err = NULL;
845 + Error *blocker = NULL;
850 + ret = global_state_store();
852 + error_report("Error saving global state");
857 + ret = bdrv_open(&bs, filename, NULL, NULL, BDRV_O_CACHE_WB, drv, &local_err);
858 + error_setg(&blocker, "block device is in use by load state");
859 + bdrv_op_block_all(bs, blocker);
862 + error_report("Could not open VM state file");
866 + /* restore the VM state */
867 + f = qemu_fopen_ops(bs, &loadstate_file_ops);
869 + error_report("Could not open VM state file");
874 + qemu_system_reset(VMRESET_SILENT);
875 + migration_incoming_state_new(f);
876 + ret = qemu_loadvm_state(f);
879 + migration_incoming_state_destroy();
881 + error_report("Error %d while loading VM state", ret);
889 + bdrv_op_unblock_all(bs, blocker);
890 + error_free(blocker);
896 ===================================================================
897 --- new.orig/migration/savevm.c 2014-11-20 09:13:01.000000000 +0100
898 +++ new/migration/savevm.c 2014-11-20 09:16:47.000000000 +0100
899 @@ -718,11 +718,11 @@
900 qemu_put_be32(f, QEMU_VM_FILE_VERSION);
903 -void qemu_savevm_state_begin(QEMUFile *f,
904 +int qemu_savevm_state_begin(QEMUFile *f,
905 const MigrationParams *params)
911 trace_savevm_state_begin();
912 QTAILQ_FOREACH(se, &savevm_state.handlers, entry) {
922 return !machine->suppress_vmdesc;
925 -void qemu_savevm_state_complete(QEMUFile *f)
926 +int qemu_savevm_state_complete(QEMUFile *f)
931 save_section_footer(f, se);
933 qemu_file_set_error(f, ret);
940 object_unref(OBJECT(vmdesc));
943 + return qemu_file_get_error(f);
946 uint64_t qemu_savevm_state_pending(QEMUFile *f, uint64_t max_size)
948 ===================================================================
949 --- new.orig/vl.c 2014-11-20 09:13:01.000000000 +0100
950 +++ new/vl.c 2014-11-20 09:16:47.000000000 +0100
951 @@ -2760,6 +2760,7 @@
954 const char *loadvm = NULL;
955 + const char *loadstate = NULL;
956 MachineClass *machine_class;
957 const char *cpu_model;
958 const char *vga_model = NULL;
959 @@ -3457,6 +3458,9 @@
960 case QEMU_OPTION_loadvm:
963 + case QEMU_OPTION_loadstate:
964 + loadstate = optarg;
966 case QEMU_OPTION_full_screen:
969 @@ -4428,6 +4432,10 @@
970 if (load_vmstate(loadvm) < 0) {
973 + } else if (loadstate) {
974 + if (load_state_from_blockdev(loadstate) < 0) {
979 qdev_prop_check_globals();