part 1 of 2.4 patch update series
[pve-qemu-kvm.git] / debian / patches / modify-query-spice.patch
blob4e5222df43d5fe7c9fa5668307b496385444e79e
1 Return last ticket with query-spice
3 We use this to implement spice seemless migration. The current spice code
4 reconnect to the migrated VM using the original ticket. So we need
5 a way to read the original ticket.
7 Limits: This only works for a single spice session.
10 Index: new/ui/spice-core.c
11 ===================================================================
12 --- new.orig/ui/spice-core.c 2014-11-20 06:45:06.000000000 +0100
13 +++ new/ui/spice-core.c 2014-11-20 07:26:43.000000000 +0100
14 @@ -544,6 +544,11 @@
15 micro = SPICE_SERVER_VERSION & 0xff;
16 info->compiled_version = g_strdup_printf("%d.%d.%d", major, minor, micro);
18 + if (auth_passwd) {
19 + info->has_ticket = true;
20 + info->ticket = g_strdup(auth_passwd);
21 + }
23 if (port) {
24 info->has_port = true;
25 info->port = port;
26 Index: new/qapi-schema.json
27 ===================================================================
28 --- new.orig/qapi-schema.json 2014-11-20 07:26:39.000000000 +0100
29 +++ new/qapi-schema.json 2014-11-20 07:26:43.000000000 +0100
30 @@ -868,11 +868,14 @@
32 # @channels: a list of @SpiceChannel for each active spice channel
34 +# @ticket: #optional The last ticket set with set_password
36 # Since: 0.14.0
38 { 'struct': 'SpiceInfo',
39 'data': {'enabled': 'bool', 'migrated': 'bool', '*host': 'str', '*port': 'int',
40 '*tls-port': 'int', '*auth': 'str', '*compiled-version': 'str',
41 + '*ticket': 'str',
42 'mouse-mode': 'SpiceQueryMouseMode', '*channels': ['SpiceChannel']} }