1 From 75eead3024d641e0ff2fa7a901a41781101cf87c Mon Sep 17 00:00:00 2001
2 From: Alexandre Derumier <aderumier@odiso.com>
3 Date: Tue, 26 Jul 2016 16:51:00 +0200
4 Subject: [PATCH 54/55] rbd: disable rbd_cache_writethrough_until_flush with
7 Signed-off-by: Alexandre Derumier <aderumier@odiso.com>
10 1 file changed, 4 insertions(+)
12 diff --git a/block/rbd.c b/block/rbd.c
13 index 5bc5b32..5656028 100644
16 @@ -544,6 +544,10 @@ static int qemu_rbd_open(BlockDriverState *bs, QDict *options, int flags,
17 rados_conf_set(s->cluster, "rbd_cache", "true");
20 + if (flags & BDRV_O_NO_FLUSH) {
21 + rados_conf_set(s->cluster, "rbd_cache_writethrough_until_flush", "false");
24 r = rados_connect(s->cluster);
26 error_setg(errp, "error connecting");