1 glusterfs: do not log to stdout if daemonized
3 Else stdout is not closed correctly.
5 Index: new/block/gluster.c
6 ===================================================================
7 --- new.orig/block/gluster.c 2014-08-22 13:21:39.000000000 +0200
8 +++ new/block/gluster.c 2014-08-22 13:25:18.000000000 +0200
10 * TODO: Use GF_LOG_ERROR instead of hard code value of 4 here when
11 * GlusterFS makes GF_LOG_* macros available to libgfapi users.
13 - ret = glfs_set_logging(glfs, "-", 4);
16 + if (!is_daemonized()) {
17 + ret = glfs_set_logging(glfs, "-", 4);
23 ret = glfs_init(glfs);