adding 2.5 pve patches and left-over extra fixes
[pve-qemu-kvm.git] / debian / patches / pve / 0004-qemu-img-return-success-on-info-without-snapshots.patch
blob212fc613e1a62552e1a75b8b6c0aac163eb291dc
1 From 12fbca3c45d694c89e84fb9522e9855b2b8a9952 Mon Sep 17 00:00:00 2001
2 From: Wolfgang Bumiller <w.bumiller@proxmox.com>
3 Date: Wed, 9 Dec 2015 14:18:46 +0100
4 Subject: [PATCH 04/41] qemu-img: return success on info without snapshots
6 ---
7 qemu-img.c | 3 ++-
8 1 file changed, 2 insertions(+), 1 deletion(-)
10 diff --git a/qemu-img.c b/qemu-img.c
11 index 033011c..e0637f2 100644
12 --- a/qemu-img.c
13 +++ b/qemu-img.c
14 @@ -2112,7 +2112,8 @@ static int img_info(int argc, char **argv)
16 list = collect_image_info_list(filename, fmt, chain);
17 if (!list) {
18 - return 1;
19 + // return success if snapshot does not exists
20 + return 0;
23 switch (output_format) {
24 --
25 2.1.4