1 From 91c8e884d18a4b76d30422b977ee03386eebe73d Mon Sep 17 00:00:00 2001
2 From: Wolfgang Bumiller <w.bumiller@proxmox.com>
3 Date: Wed, 9 Dec 2015 14:33:34 +0100
4 Subject: [PATCH 10/41] ui/spice: default to pve certs unless otherwise
8 ui/spice-core.c | 15 +++++++++------
9 1 file changed, 9 insertions(+), 6 deletions(-)
11 diff --git a/ui/spice-core.c b/ui/spice-core.c
12 index 05d24a1..6ed91f6 100644
15 @@ -669,32 +669,35 @@ void qemu_spice_init(void)
18 x509_dir = qemu_opt_get(opts, "x509-dir");
23 str = qemu_opt_get(opts, "x509-key-file");
25 x509_key_file = g_strdup(str);
27 + } else if (x509_dir) {
28 x509_key_file = g_strdup_printf("%s/%s", x509_dir,
29 X509_SERVER_KEY_FILE);
31 + x509_key_file = g_strdup("/etc/pve/local/pve-ssl.key");
34 str = qemu_opt_get(opts, "x509-cert-file");
36 x509_cert_file = g_strdup(str);
38 + } else if (x509_dir) {
39 x509_cert_file = g_strdup_printf("%s/%s", x509_dir,
40 X509_SERVER_CERT_FILE);
42 + x509_cert_file = g_strdup("/etc/pve/local/pve-ssl.pem");
45 str = qemu_opt_get(opts, "x509-cacert-file");
47 x509_cacert_file = g_strdup(str);
49 + } else if (x509_dir) {
50 x509_cacert_file = g_strdup_printf("%s/%s", x509_dir,
53 + x509_cacert_file = g_strdup("/etc/pve/pve-root-ca.pem");
56 x509_key_password = qemu_opt_get(opts, "x509-key-password");