1 From 34ccb14434cfc6b61e568aa076bc09231df45981 Mon Sep 17 00:00:00 2001
2 From: Wolfgang Bumiller <w.bumiller@proxmox.com>
3 Date: Wed, 9 Dec 2015 16:33:10 +0100
4 Subject: [PATCH 26/41] glusterfs: daemonize
7 block/gluster.c | 8 +++++---
8 1 file changed, 5 insertions(+), 3 deletions(-)
10 diff --git a/block/gluster.c b/block/gluster.c
11 index 0857c14..e3c0dbc 100644
14 @@ -196,9 +196,11 @@ static struct glfs *qemu_gluster_init(GlusterConf *gconf, const char *filename,
15 * TODO: Use GF_LOG_ERROR instead of hard code value of 4 here when
16 * GlusterFS makes GF_LOG_* macros available to libgfapi users.
18 - ret = glfs_set_logging(glfs, "-", 4);
21 + if (!is_daemonized()) {
22 + ret = glfs_set_logging(glfs, "-", 4);
28 ret = glfs_init(glfs);