1 From 220fb93343dc6c05989c903873d8ed68943848ef Mon Sep 17 00:00:00 2001
2 From: Wolfgang Bumiller <w.bumiller@proxmox.com>
3 Date: Fri, 21 Oct 2016 09:09:26 +0200
4 Subject: [PATCH 43/48] vma: sizes passed to blk_co_preadv should be bytes now
8 1 file changed, 2 insertions(+), 2 deletions(-)
10 diff --git a/vma.c b/vma.c
11 index 4f55799..0491542 100644
14 @@ -466,8 +466,8 @@ static void coroutine_fn backup_run(void *opaque)
15 iov.iov_len = VMA_CLUSTER_SIZE;
16 qemu_iovec_init_external(&qiov, &iov, 1);
18 - ret = blk_co_preadv(job->target, start * BACKUP_SECTORS_PER_CLUSTER,
19 - BACKUP_SECTORS_PER_CLUSTER, &qiov, 0);
20 + ret = blk_co_preadv(job->target, start * VMA_CLUSTER_SIZE,
21 + VMA_CLUSTER_SIZE, &qiov, 0);
23 vma_writer_set_error(job->vmaw, "read error", -1);