1 inherit common-lisp-2 eutils
3 DESCRIPTION
="High-level Common Lisp wrapper around libxml2 and libxslt libraries"
4 HOMEPAGE
="http://code.google.com/p/cl-libxml2/"
5 SRC_URI
="http://cl-libxml2.googlecode.com/files/${P}.tar.bz2"
9 KEYWORDS
="~amd64 ~ppc ~sparc ~x86"
12 RDEPEND
="dev-libs/libxml2
14 >=dev-lisp/cffi-0.10.2
15 >=dev-lisp/garbage-pools-0.1.1
17 dev-lisp/flexi-streams
18 dev-lisp/metabang-bind
21 CLSYSTEMS
="${PN} cl-libxslt xfactory"
24 make -C foreign || die
"Cannot build cllibxml2 helper library"
28 common-lisp-install
*.asd
29 common-lisp-install tree
/*.lisp
30 common-lisp-install html
/*.lisp
31 common-lisp-install xpath
/*.lisp
32 common-lisp-install xslt
/*.lisp
33 common-lisp-install test
/*.lisp
34 common-lisp-symlink-asdf
36 exeinto
/usr
/$
(get_libdir
)/ ; doexe foreign
/cllibxml2.so
39 docinto examples
&& dodoc examples
/*