Update svn merge history.
[sdcc.git] / sdcc / sdcc.spec
bloba3170b46800a65e6e73b217a935fb44600179e05
2 # spec file for package sdcc
5 Name: sdcc
6 Requires: /bin/sh
7 License: GPL
8 Group: Applications/Engineering
9 Summary: Small Device C Compiler
10 Requires: sdcc-common
11 Version: 4.5.0
12 Release: 1
13 Source: %{name}-src-%{version}.tar.gz
14 URL: http://sdcc.sourceforge.net/
15 Packager: Philipp Klaus Krause <philipp@colecovision.eu>
16 BuildRoot: %{_tmppath}/%{name}-%{version}-build
18 %description
19 SDCC is a free open source, retargettable, optimizing Standard C compiler
20 suite that targets a growing list of processors including the Intel
21 MCS51 based microprocessors (8031, 8032, 8051, 8052, etc.), Maxim
22 (formerly Dallas) DS80C390 variants, NXP (formerly Freescale/Motorola)
23 HC08 based (hc08, s08), Zilog Z80 based MCUs (Z80, Z180, SM83,
24 Rabbit 2000 / 2000A / 3000A, TLCS-90, eZ80 in Z80 mode, Z80N), the STM8
25 and the Padauk PDK14 and PDK15.
26 Work is in progress on supporting the Padauk PDK13 and MOS 6502 targets.
27 There is unmaintained support for the Microchip PIC16 and PIC18.
28 SDCC can be retargeted for other microprocessors.
30 %package common
31 License: GPL, LGPL
32 Group: Application/Engineering
33 Summary: Libraries and Header Files for the SDCC C compiler
34 Requires: sdcc
36 %description common
37 SDCC is a free open source, retargettable, optimizing Standard C compiler
38 suite that targets a growing list of processors including the Intel
39 MCS51 based microprocessors (8031, 8032, 8051, 8052, etc.), Maxim
40 (formerly Dallas) DS80C390 variants, NXP (formerly Freescale/Motorola)
41 HC08 based (hc08, s08), Zilog Z80 based MCUs (Z80, Z180, SM83,
42 Rabbit 2000 / 2000A / 3000A, TLCS-90, eZ80 in Z80 mode, Z80N), the STM8
43 and the Padauk PDK14 and PDK15.
44 Work is in progress on supportine the Padauk PDK13 and MOS 6502 targets.
45 There is unmaintained support for the Microchip PIC16 and PIC18.
46 SDCC can be retargeted for other microprocessors.
48 %package doc
49 License: GPL
50 Group: Applications/Engineering
51 Summary: Documentation for the SDCC C compiler
53 %description doc
54 SDCC is a free open source, retargettable, optimizing Standard C compiler
55 suite that targets a growing list of processors including the Intel
56 MCS51 based microprocessors (8031, 8032, 8051, 8052, etc.), Maxim
57 (formerly Dallas) DS80C390 variants, NXP (formerly Freescale/Motorola)
58 HC08 based (hc08, s08), Zilog Z80 based MCUs (Z80, Z180, SM83,
59 Rabbit 2000 / 2000A / 3000A, TLCS-90, eZ80 in Z80 mode, Z80N), the STM8
60 and the Padauk PDK14 and PDK15.
61 Work is in progress on supportine the Padauk PDK13 and MOS 6502 targets.
62 There is unmaintained support for the Microchip PIC16 and PIC18.
63 SDCC can be retargeted for other microprocessors.
65 %prep
66 %setup -n sdcc
68 %build
69 ./configure CFLAGS="$RPM_OPT_FLAGS" --prefix=/usr --enable-doc docdir=$RPM_BUILD_ROOT/%{_defaultdocdir}/%{name}
70 make
71 cd doc
72 make
73 cd ..
75 %install
76 rm -rf $RPM_BUILD_ROOT
77 make prefix=$RPM_BUILD_ROOT/usr install
78 cd doc
79 make install
80 cd ..
82 %clean
83 rm -rf $RPM_BUILD_ROOT
85 %files
86 %defattr(-,root,root)
87 /usr/bin
89 %files common
90 %defattr(-,root,root)
91 /usr/share/sdcc/include
92 /usr/share/sdcc/non-free/include
93 /usr/share/sdcc/lib
94 /usr/share/sdcc/non-free/lib
96 %files doc
97 %defattr(-,root,root)
98 %doc %{_defaultdocdir}
100 %changelog
101 * Mon Feb 14 2022 - philipp AT colecovision.eu
102 - version updated to 4.4.0
103 * Mon Feb 14 2022 - krauseph AT informatik.uni-freiburg.de
104 - version updated to 4.2.0
105 * Sat Feb 20 2021 - pkk AT spth.de
106 - version updated to 4.0.0
107 * Sat Jan 18 2020 - pkk AT spth.de
108 - version updated to 4.0.0
109 * Fri Apr 05 2019 - krauseph AT informatik.uni-freiburg.de
110 - version updated to 3.9.0
111 * Sun Sep 16 2018 - pkk AT spth.de
112 - version updated to 3.8.0
113 * Wed Feb 07 2018 - pkk AT spth.de
114 - version updated to 3.7.0
115 * Sun May 29 2016 - sourceforge.brock AT dse.nl
116 - version updated to 3.6.0
117 * Fri Jun 06 2015 - sourceforge.brock AT dse.nl
118 - version updated to 3.5.0
119 * Fri Feb 28 2014 - sourceforge.brock AT dse.nl
120 - version updated to 3.4.0
121 * Sat May 04 2013 - sourceforge.brock AT dse.nl
122 - version updated to 3.3.0
123 * Fri Jun 12 2012 - borut.razem AT siol.net
124 - version updated to 3.2.0
125 * Sat Oct 08 2010 - borut.razem AT siol.net
126 - added non-free include and lib directories
127 - version updated to 3.1.0
128 * Sun Dec 26 2006 - bernhard AT bernhardheld.de
129 - version updated
130 * Sun Sep 03 2006 - Christer Weinigel
131 - fixed build of doc
132 * Tue Mar 09 2004 - bernhard AT bernhardheld.de
133 - split into two packages
134 * Wed Feb 26 2004 - bernhard AT bernhardheld.de
135 - version updated
136 * Sun Jan 04 2004 - bernhard AT bernhardheld.de
137 - updated
138 * Sat Apr 27 2002 - steve AT icarus.com
139 - first version from Stephen Williams