1 # Copyright 1999-2019 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
5 inherit eutils git-r3 multilib savedconfig toolchain-funcs
7 DESCRIPTION
="simple terminal implementation for Wayland"
8 HOMEPAGE
="http://st.suckless.org/"
9 EGIT_REPO_URI
="https://github.com/michaelforney/st.git"
12 LICENSE
="MIT-with-advertising"
17 !<sys-libs/ncurses-6.0
29 epatch
"${FILESDIR}/rename-with-wl-suffix.patch"
32 sed -e '/^CFLAGS/s:[[:space:]]-Wall[[:space:]]: :' \
33 -e '/^CFLAGS/s:[[:space:]]-O[^[:space:]]*[[:space:]]: :' \
34 -e '/^LDFLAGS/{s:[[:space:]]-s[[:space:]]: :}' \
35 -e '/^X11INC/{s:/usr/X11R6/include:/usr/include/X11:}' \
36 -e "/^X11LIB/{s:/usr/X11R6/lib:/usr/$(get_libdir)/X11:}" \
38 sed -e '/@echo/!s:@::' \
43 restore_config config.h
47 emake DESTDIR
="${D}" PREFIX
="${EPREFIX}"/usr
install
54 if ! [[ "${REPLACING_VERSIONS}" ]]; then
55 elog
"Please ensure a usable font is installed, like"
56 elog
" media-fonts/corefonts"
57 elog
" media-fonts/dejavu"
58 elog
" media-fonts/urw-fonts"