dev-lua/wcwidth: rewrite for modern lua eclass
[sgilles-overlay.git] / gui-apps / st-wl / st-wl-9999.ebuild
blob64837d9352e8f2379e70c06f9b5a0a89ee508ba6
1 # Copyright 1999-2019 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
5 inherit eutils git-r3 multilib savedconfig toolchain-funcs
7 DESCRIPTION="simple terminal implementation for Wayland"
8 HOMEPAGE="http://st.suckless.org/"
9 EGIT_REPO_URI="https://github.com/michaelforney/st.git"
10 EGIT_BRANCH="wayland"
12 LICENSE="MIT-with-advertising"
13 SLOT="0"
14 IUSE="savedconfig"
16 RDEPEND="
17 !<sys-libs/ncurses-6.0
18 media-libs/fontconfig
19 dev-libs/wayland
20 dev-libs/wld[wayland]
21 x11-libs/libxkbcommon
23 DEPEND="
24 ${RDEPEND}
25 virtual/pkgconfig
28 src_prepare() {
29 epatch "${FILESDIR}/rename-with-wl-suffix.patch"
30 eapply_user
32 sed -e '/^CFLAGS/s:[[:space:]]-Wall[[:space:]]: :' \
33 -e '/^CFLAGS/s:[[:space:]]-O[^[:space:]]*[[:space:]]: :' \
34 -e '/^LDFLAGS/{s:[[:space:]]-s[[:space:]]: :}' \
35 -e '/^X11INC/{s:/usr/X11R6/include:/usr/include/X11:}' \
36 -e "/^X11LIB/{s:/usr/X11R6/lib:/usr/$(get_libdir)/X11:}" \
37 -i config.mk || die
38 sed -e '/@echo/!s:@::' \
39 -e '/tic/d' \
40 -i Makefile || die
41 tc-export CC
43 restore_config config.h
46 src_install() {
47 emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
48 dodoc TODO
50 save_config config.h
53 pkg_postinst() {
54 if ! [[ "${REPLACING_VERSIONS}" ]]; then
55 elog "Please ensure a usable font is installed, like"
56 elog " media-fonts/corefonts"
57 elog " media-fonts/dejavu"
58 elog " media-fonts/urw-fonts"