app-editors/vis: remove
[sgilles-overlay.git] / sys-apps / diffutils / diffutils-3.3.ebuild
blob73f01cd629797d0d1a97473c666e79b6dc254fac
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/sys-apps/diffutils/diffutils-3.3.ebuild,v 1.15 2015/07/21 15:56:38 vapier Exp $
5 EAPI=4
7 inherit flag-o-matic
9 DESCRIPTION="Tools to make diffs and compare files"
10 HOMEPAGE="http://www.gnu.org/software/diffutils/"
11 SRC_URI="mirror://gnu-alpha/diffutils/${P}.tar.xz
12 mirror://gnu/diffutils/${P}.tar.xz"
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
17 IUSE="nls static"
19 DEPEND="app-arch/xz-utils
20 nls? ( sys-devel/gettext )"
22 DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
24 src_prepare() {
25 # Disable gnulib build test that has no impact on the source.
26 # Re-enable w/next version bump (and gnulib is updated). #554728
27 [[ ${PV} != "3.3" ]] && die "re-enable test #554728"
28 echo 'exit 0' > gnulib-tests/test-update-copyright.sh || die
30 sed -i 's:@mkdir_p@:@MKDIR_P@:g' po/Makefile.in.in || die #464604
33 src_configure() {
34 use static && append-ldflags -static
36 # Disable automagic dependency over libsigsegv; see bug #312351.
37 export ac_cv_libsigsegv=no
39 econf \
40 --with-included-regex \
41 --with-packager="Gentoo" \
42 --with-packager-version="${PVR}" \
43 --with-packager-bug-reports="http://bugs.gentoo.org/" \
44 $(use_enable nls)
47 src_test() {
48 # explicitly allow parallel testing
49 emake check