app-text/fbpdf: reload, not redraw
[sgilles-overlay.git] / compositor / velox / velox-9999.ebuild
blob0a462c5feb5724c308cd952e0d2c8a0526e87230
1 # Copyright 2014 Michael Forney
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=6
6 EGIT_REPO_URI="git://github.com/michaelforney/velox.git"
7 KEYWORDS="~amd64 ~arm"
8 SRC_URI=""
10 inherit git-r3
12 DESCRIPTION="velox is a tiling Wayland compositor based on swc"
13 HOMEPAGE="https://github.com/michaelforney/velox"
15 LICENCES="MIT"
16 SLOT="0"
17 IUSE=""
19 DEPEND="compositor/swc dev-libs/wld[wayland] x11-libs/libxkbcommon"
20 RDEPEND="${DEPEND}"
22 src_configure() {
23     tee config.mk << EOF
24 PREFIX = ${EPREFIX}/usr
25 LIBDIR = ${EPREFIX}/usr/$(get_libdir)
26 DATADIR = /usr/share
27 EOF
30 src_install() {
31         emake DESTDIR="${D}" install
33         insinto "/usr/share/velox"
34         newins velox.conf.sample velox.conf