Bump nci 1.0.1 -> 1.1.0
[sgilles-overlay.git] / games-engines / onscripter-en / onscripter-en-20110628-r1.ebuild
blob27381135e95de021cdc5847dcc182f644677bba8
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=2
7 inherit eutils games
9 DESCRIPTION="A fork of the ONScripter engine with added English support"
10 HOMEPAGE="http://onscripter.denpa.mobi/?page_id=26"
11 SRC_URI="http://onscripter.denpa.mobi/pub/onscr/${P}-src.tar.bz2"
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="scale"
18 DEPEND="media-libs/sdl-image[jpeg,png]
19         media-libs/sdl-mixer[mp3,vorbis]
20         media-libs/sdl-ttf
21         media-libs/smpeg
22         app-arch/bzip2"
23 RDEPEND="${DEPEND}"
25 S="${WORKDIR}/${P}-src"
27 src_prepare() {
28         edos2unix configure
29         epatch "${FILESDIR}"/${PN}-20110314-compiler.patch
31         if use scale; then
32         sed -i \
33                 -e 's:-DLINUX:-DLINUX -DRCA_SCALE:' configure \
34                 || die "sed failed"
35         fi
38 src_configure() {
39         #emacs -nw configure
40         egamesconf --no-werror || die
43 src_install() {
44         dogamesbin ${PN} || die "dogamesbin failed"
45         dodoc CHANGES INSTALL README || die "dodoc failed"
47         prepgamesdirs