1 # Copyright 1999-2019 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 LUA_COMPAT=( lua5-{1..4} luajit )
10 DESCRIPTION="Lua bindings for unibilium"
11 HOMEPAGE="https://repo.or.cz/lua-unibilium.git"
12 EGIT_REPO_URI="https://repo.or.cz/lua-unibilium.git"
14 if [[ "${PV}" == *999* ]]; then
26 >=dev-libs/unibilium-2.0.0"
38 pushd "${BUILD_DIR}" || die
43 "LUAINC_linux=$(lua_get_include_dir)"
44 "CFLAGS=${CFLAGS} -I$(lua_get_include_dir)"
48 emake "${myemakeargs[@]}"
54 lua_foreach_impl lua_src_compile
58 pushd "${BUILD_DIR}" || die
61 "INSTALL_CMOD=${ED}/$(lua_get_cmod_dir)"
62 "INSTALL_LMOD=${ED}/$(lua_get_lmod_dir)"
65 emake "${emakeargs[@]}" install
71 lua_foreach_impl lua_src_install