media-gfx/jpeg-xl: add
[sgilles-overlay.git] / media-gfx / jpeg-xl / jpeg-xl-9999.ebuild
blobae7defe0cd2286942eff255ae63e7dc22389e246
1 # Copyright 1999-2020 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 inherit eutils git-r3 cmake-utils toolchain-funcs
8 DESCRIPTION="Reference implementation of JPEG XL (encoder and decoder)"
9 HOMEPAGE="https://jpeg.org/jpegxl/index.html"
10 EGIT_REPO_URI="https://gitlab.com/wg1/jpeg-xl"
11 EGIT_SUBMODULES=( '*' '-third_party/mingw-std-threads' )
13 LICENSE="Apache-2.0"
14 SLOT="0"
16 if [[ ${PV} == 9999 ]]
17 then
19 else
20 EGIT_COMMIT="${PV}"
21 KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ~ppc ppc64 ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
24 IUSE=""
25 RDEPEND="media-gfx/sjpeg"
26 DEPEND="${RDEPEND}
27 >=sys-devel/clang-6
30 PATCHES=(
34 src_configure() {
35 export CC=clang
36 export CXX=clang++
38 cmake-utils_src_configure