1 # Copyright 1999-2019 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 LUA_COMPAT=( lua5-{1..4} luajit )
10 DESCRIPTION="A lua library to spawn programs"
11 HOMEPAGE="https://github.com/daurnimator/lua-spawn"
12 EGIT_REPO_URI="https://github.com/daurnimator/lua-spawn"
13 EGIT_COMMIT="b2f1629754a3e78edab1f69c71e7d7334cbe4e92"
14 KEYWORDS="~amd64 ~arm ~x86"
19 PATCHES=( "${FILESDIR}/${P}_makefile.patch" )
36 pushd "${BUILD_DIR}" || die
41 "LUAINC_linux=$(lua_get_include_dir)"
43 "MYLDFLAGS=${LDFLAGS}"
46 emake "${myemakeargs[@]}"
52 lua_foreach_impl lua_src_compile
56 pushd "${BUILD_DIR}" || die
59 "INSTALL_CMOD=${ED}/$(lua_get_cmod_dir)"
60 "INSTALL_LMOD=${ED}/$(lua_get_lmod_dir)"
63 emake "${emakeargs[@]}" install
69 lua_foreach_impl lua_src_install