media-libs/libschrift: add
[sgilles-overlay.git] / dev-lua / lua-spawn / lua-spawn-0.1.20190307.ebuild
blobe8f49e9ac7ceba7721a23b1e4e6cb59c3a4aff2e
1 # Copyright 1999-2019 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 LUA_COMPAT=( lua5-{1..4} luajit )
8 inherit lua git-r3
10 DESCRIPTION="A lua library to spawn programs"
11 HOMEPAGE="https://github.com/daurnimator/lua-spawn"
12 EGIT_REPO_URI="https://github.com/daurnimator/lua-spawn"
13 EGIT_COMMIT="b2f1629754a3e78edab1f69c71e7d7334cbe4e92"
14 KEYWORDS="~amd64 ~arm ~x86"
16 LICENSE="MIT"
17 SLOT="0"
19 PATCHES=( "${FILESDIR}/${P}_makefile.patch" )
21 DEPEND="
22         ${LUA_DEPS}
23         dev-lua/lunix
25 RDEPEND="
26         ${DEPEND}
29 src_prepare() {
30         default
32         lua_copy_sources
35 lua_src_compile() {
36         pushd "${BUILD_DIR}" || die
38         local myemakeargs=(
39                 "CC=$(tc-getCC)"
40                 "LD=$(tc-getCC)"
41                 "LUAINC_linux=$(lua_get_include_dir)"
42                 "MYCFLAGS=${CFLAGS}"
43                 "MYLDFLAGS=${LDFLAGS}"
44         )
46         emake "${myemakeargs[@]}"
48         popd
51 src_compile() {
52         lua_foreach_impl lua_src_compile
55 lua_src_install () {
56         pushd "${BUILD_DIR}" || die
58         local emakeargs=(
59                 "INSTALL_CMOD=${ED}/$(lua_get_cmod_dir)"
60                 "INSTALL_LMOD=${ED}/$(lua_get_lmod_dir)"
61         )
63         emake "${emakeargs[@]}" install
65         popd
68 src_install() {
69         lua_foreach_impl lua_src_install
71         einstalldocs