media-libs/libschrift: add
[sgilles-overlay.git] / gui-wm / velox / velox-9999.ebuild
blob39ecb3a6fa01e51999210a4c9ef4b2ac86b5b393
1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=7
6 EGIT_REPO_URI="git://github.com/michaelforney/velox.git"
7 KEYWORDS="~amd64 ~arm"
8 SRC_URI=""
10 inherit git-r3
12 DESCRIPTION="velox is a tiling Wayland compositor based on swc"
13 HOMEPAGE="https://github.com/michaelforney/velox"
15 LICENCES="MIT"
16 SLOT="0"
17 IUSE=""
19 DEPEND="
20         gui-libs/swc
21         dev-libs/wld[wayland]
22         x11-libs/libxkbcommon
24 RDEPEND="${DEPEND}"
26 src_configure() {
27     tee config.mk << EOF
28 PREFIX = ${EPREFIX}/usr
29 LIBDIR = ${EPREFIX}/usr/$(get_libdir)
30 DATADIR = /usr/share
31 EOF
34 src_install() {
35         emake DESTDIR="${D}" install
37         insinto "/usr/share/velox"
38         newins velox.conf.sample velox.conf