media-libs/libschrift: add
[sgilles-overlay.git] / media-fonts / tewi-font / tewi-font-2.0.0-r1.ebuild
blob0c232c64b1dc5e46d30685a8a593716e06574b28
1 EAPI=7
3 PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
5 inherit font python-any-r1
7 DESCRIPTION="a bitmap font"
8 HOMEPAGE="https://github.com/lucy/tewi-font"
9 if [[ ${PV} != *9999* ]]; then
10 SRC_URI="https://github.com/lucy/tewi-font/archive/${PV}.tar.gz -> ${P}.tar.gz"
11 KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
12 else
13 EGIT_REPO_URI="https://github.com/lucy/tewi-font.git"
14 inherit git-r3
17 LICENSE="MIT"
18 SLOT="0"
20 IUSE="+pcf bdf"
22 RDEPEND=""
23 DEPEND="${PYTHON_DEPS}
24 pcf? ( x11-apps/bdftopcf )"
26 src_compile() {
27 if use pcf; then
28 emake
31 if use bdf; then
32 emake var
36 src_install() {
37 insinto "/usr/share/fonts/${PN}"
38 if use pcf; then
39 doins out/*
42 if use bdf; then
43 doins *.bdf
45 font_src_install