1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
8 AUTOTOOLS_IN_SOURCE_BUILD
=1
9 inherit autotools-utils
11 DESCRIPTION
="Command line tools and C library for accessing Mega cloud storage"
12 HOMEPAGE
="https://github.com/megous/megatools"
13 SRC_URI
="https://github.com/megous/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
17 KEYWORDS
="~amd64 ~arm ~x86"
18 IUSE
="fuse introspection libressl static-libs"
20 COMMON_DEPEND
="dev-libs/glib:2
21 !libressl? ( dev-libs/openssl:0 )
22 libressl? ( dev-libs/libressl )
26 RDEPEND
="${COMMON_DEPEND}
27 net-libs/glib-networking[ssl]
29 DEPEND
="${COMMON_DEPEND}
37 --disable-maintainer-mode
40 $
(use_enable static-libs static
)
41 $
(use_enable introspection
)
44 autotools-utils_src_configure