net-misc/megatools: bump
[sgilles-overlay.git] / net-misc / megatools / megatools-1.9.97-r1.ebuild
bloba62947a16706ea5afb5010582388915f464c38f5
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
5 EAPI=5
7 AUTOTOOLS_AUTORECONF=1
8 AUTOTOOLS_IN_SOURCE_BUILD=1
9 inherit autotools-utils
11 DESCRIPTION="Command line tools and C library for accessing Mega cloud storage"
12 HOMEPAGE="https://github.com/megous/megatools"
13 SRC_URI="https://github.com/megous/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
15 LICENSE="GPL-2"
16 SLOT="0"
17 KEYWORDS="~amd64 ~arm ~x86"
18 IUSE="fuse introspection libressl static-libs"
20 COMMON_DEPEND="dev-libs/glib:2
21 !libressl? ( dev-libs/openssl:0 )
22 libressl? ( dev-libs/libressl )
23 net-misc/curl
24 fuse? ( sys-fs/fuse )
26 RDEPEND="${COMMON_DEPEND}
27 net-libs/glib-networking[ssl]
29 DEPEND="${COMMON_DEPEND}
30 virtual/pkgconfig
31 app-text/asciidoc"
33 src_configure() {
34 local myeconfargs=(
35 --enable-shared
36 --enable-docs-build
37 --disable-maintainer-mode
38 --disable-warnings
39 --disable-glibtest
40 $(use_enable static-libs static)
41 $(use_enable introspection)
42 $(use_with fuse)
44 autotools-utils_src_configure