net-misc/megatools: bump
[sgilles-overlay.git] / sys-apps / fbset / fbset-2.1.ebuild
blobbe2d4532271e48fcdc8e03b8ea0e7960f9cc3cf4
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 EAPI=6
5 inherit toolchain-funcs flag-o-matic eutils
7 DESCRIPTION="A utility to set the framebuffer videomode"
8 HOMEPAGE="http://users.telenet.be/geertu/Linux/fbdev/"
9 SRC_URI="http://users.telenet.be/geertu/Linux/fbdev/${P}.tar.gz"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sh sparc x86"
14 IUSE="static"
16 DEPEND="sys-devel/bison
17 sys-devel/flex"
18 RDEPEND=""
20 PATCHES=(
21 "${FILESDIR}/${P}-build.patch"
22 "${FILESDIR}/${P}-__u32.patch"
25 src_compile() {
26 use static && append-ldflags -static
27 tc-export CC
28 emake || die "emake failed"
31 src_install() {
32 dobin fbset modeline2fb || die "dobin failed"
33 doman *.[58]
34 dodoc etc/fb.modes.* INSTALL