net-misc/vde: remove
[sgilles-overlay.git] / media-sound / streamripper / streamripper-1.64.0.ebuild
blob195aa8e3764b6cad09b9032c9ae28ee2d980017a
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/streamripper-1.64.0.ebuild,v 1.8 2012/05/05 08:53:55 mgorny Exp $
5 DESCRIPTION="Extracts and records individual MP3 file tracks from shoutcast streams"
6 HOMEPAGE="http://streamripper.sourceforge.net"
7 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
9 LICENSE="GPL-2"
10 SLOT="0"
11 KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
12 IUSE="vorbis"
14 RDEPEND="media-libs/libmad
15         media-libs/faad2
16         >=dev-libs/glib-2.16
17         vorbis? ( media-libs/libvorbis )"
18 DEPEND="${RDEPEND}
19         virtual/pkgconfig"
21 src_compile() {
22         econf --disable-dependency-tracking $(use_with vorbis ogg) \
23                 --without-included-libmad --without-included-glib \
24                 --without-included-argv --without-included-cdk
25         emake || die "emake failed."
28 src_install() {
29         emake DESTDIR="${D}" install || die "emake install failed."
30         dodoc CHANGES README THANKS