dev-embedded/stlink: add
[sgilles-overlay.git] / app-i18n / fbterm / fbterm-1.7-r2.ebuild
blobcea3105cc1080b1e02996e468c93f6d895d69ca9
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
5 EAPI="5"
6 inherit autotools-utils
8 DESCRIPTION="Fast terminal emulator for the Linux framebuffer"
9 HOMEPAGE="https://fbterm.googlecode.com/"
10 SRC_URI="https://fbterm.googlecode.com/files/${P}.0.tar.gz"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~arm64 ~x86"
15 IUSE="caps gpm video_cards_vesa"
17 RDEPEND="caps? ( sys-libs/libcap )
18 gpm? ( sys-libs/gpm )
19 video_cards_vesa? ( dev-libs/libx86 )
20 media-libs/fontconfig
21 media-libs/freetype:2"
22 DEPEND="${RDEPEND}
23 sys-libs/ncurses
24 virtual/pkgconfig"
26 AUTOTOOLS_IN_SOURCE_BUILD=1
28 DOCS=( AUTHORS NEWS README )
30 src_prepare() {
31 epatch "${FILESDIR}/${P}-0001-proper-casts-for-sentinals.patch"
32 epatch "${FILESDIR}/${P}-0002-remove-cdefs.h.patch"
33 epatch "${FILESDIR}/${P}-0003-use-system-signalfd.h.patch"
34 epatch "${FILESDIR}/${P}-0004-do-not-use-WAIT_ANY.patch"
35 epatch "${FILESDIR}/${P}-0005-fix-improxy-includes.patch"
38 src_configure() {
39 local myeconfargs=(
40 $(use_enable gpm)
41 $(use_enable video_cards_vesa vesa)
43 autotools-utils_src_configure
46 src_install() {
47 autotools-utils_src_install
48 $(type -P tic) -o "${ED}/usr/share/terminfo/" \
49 "${S}"/terminfo/fbterm || die "Failed to generate terminfo database"
50 if use caps; then
51 setcap "cap_sys_tty_config+ep" "${ED}"/usr/bin/fbterm
52 else
53 fperms u+s /usr/bin/fbterm
57 pkg_postinst() {
58 einfo
59 einfo " ${PN} won't work with vga16fb. You have to use other native"
60 einfo " framebuffer drivers or vesa driver."
61 einfo " See ${EPREFIX}/usr/share/doc/${P}/README for details."
62 einfo " To use ${PN}, ensure you are in video group."
63 einfo " To input CJK merge app-i18n/fbterm-ucimf"
64 einfo