1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 inherit autotools-utils
8 DESCRIPTION
="Fast terminal emulator for the Linux framebuffer"
9 HOMEPAGE
="https://fbterm.googlecode.com/"
10 SRC_URI
="https://fbterm.googlecode.com/files/${P}.0.tar.gz"
14 KEYWORDS
="~amd64 ~arm64 ~x86"
15 IUSE
="caps gpm video_cards_vesa"
17 RDEPEND
="caps? ( sys-libs/libcap )
19 video_cards_vesa? ( dev-libs/libx86 )
21 media-libs/freetype:2"
26 AUTOTOOLS_IN_SOURCE_BUILD
=1
28 DOCS
=( AUTHORS NEWS README
)
31 epatch
"${FILESDIR}/${P}-0001-proper-casts-for-sentinals.patch"
32 epatch
"${FILESDIR}/${P}-0002-remove-cdefs.h.patch"
33 epatch
"${FILESDIR}/${P}-0003-use-system-signalfd.h.patch"
34 epatch
"${FILESDIR}/${P}-0004-do-not-use-WAIT_ANY.patch"
35 epatch
"${FILESDIR}/${P}-0005-fix-improxy-includes.patch"
41 $
(use_enable video_cards_vesa vesa
)
43 autotools-utils_src_configure
47 autotools-utils_src_install
48 $
(type -P tic
) -o "${ED}/usr/share/terminfo/" \
49 "${S}"/terminfo
/fbterm || die
"Failed to generate terminfo database"
51 setcap
"cap_sys_tty_config+ep" "${ED}"/usr
/bin
/fbterm
53 fperms u
+s
/usr
/bin
/fbterm
59 einfo
" ${PN} won't work with vga16fb. You have to use other native"
60 einfo
" framebuffer drivers or vesa driver."
61 einfo
" See ${EPREFIX}/usr/share/doc/${P}/README for details."
62 einfo
" To use ${PN}, ensure you are in video group."
63 einfo
" To input CJK merge app-i18n/fbterm-ucimf"