1 # Copyright 1999-2020 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
8 DESCRIPTION
="stm32 discovery line linux programmer"
9 HOMEPAGE
="https://github.com/texane/stlink"
10 if [[ ${PV} == "9999" ]]; then
11 EGIT_REPO_URI
="https://github.com/texane/stlink.git"
14 SRC_URI
="https://github.com/texane/stlink/archive/v${PV}.tar.gz -> ${P}.tar.gz"
23 RDEPEND
="virtual/libusb:1
24 >=dev-libs/glib-2.32.0:2
25 gtk3? ( x11-libs/gtk+:3 )"
27 BDEPEND
="virtual/pkgconfig"
31 -DSTLINK_UDEV_RULES_DIR="$(get_udevdir)"/rules.d
32 -DSTLINK_MODPROBED_DIR="${EPREFIX}/etc/modprobe.d"
33 -DSTLINK_STATIC_LIB=OFF
34 -DLIB_INSTALL_DIR:PATH
="$(get_libdir)"