net-mail/ssmtp: remove (libressl stuff is gone now)
[sgilles-overlay.git] / dev-libs / wld / wld-9999.ebuild
blob6c5293bc0ca87ced45eeac411d28d0443e2b9f28
1 # Copyright 2013, 2014 Michael Forney
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=6
6 inherit git-r3
8 DESCRIPTION="WLD is a primitive drawing library targeted at Wayland"
9 HOMEPAGE="https://github.com/michaelforney/wld"
10 EGIT_REPO_URI="git://github.com/michaelforney/wld.git"
11 SRC_URI=""
13 LICENCE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64 ~arm"
16 VIDEO_CARDS="intel nouveau"
17 for card in ${VIDEO_CARDS}; do
18 IUSE_VIDEO_CARDS+=" video_cards_${card}"
19 done
20 IUSE="${IUSE_VIDEO_CARDS} drm wayland"
22 RDEPEND="
23 media-libs/fontconfig
24 >=media-libs/freetype-2.0.0
25 x11-libs/pixman
26 drm? ( x11-libs/libdrm[video_cards_intel?,video_cards_nouveau?] )
27 wayland? ( dev-libs/wayland )
30 DEPEND="${RDEPEND}"
32 src_configure() {
33 local drm_drivers=( ) wayland_interfaces=( )
35 use video_cards_intel && drm_drivers+=( intel )
36 use video_cards_nouveau && drm_drivers+=( nouveau )
37 use drm && use wayland && wayland_interfaces+=( drm )
38 use wayland && wayland_interfaces+=( shm )
40 cat > config.mk <<EOF
41 PREFIX = ${EPREFIX}/usr
42 LIBDIR = ${EPREFIX}/usr/$(get_libdir)
44 ENABLE_STATIC = 1
45 ENABLE_SHARED = 1
46 ENABLE_PIXMAN = 1
47 ENABLE_DEBUG = 1
48 ENABLE_DRM = $(usex drm 1 0)
49 ENABLE_WAYLAND = $(usex wayland 1 0)
50 DRM_DRIVERS = ${drm_drivers[*]}
51 WAYLAND_INTERFACES = ${wayland_interfaces[*]}
52 EOF
54 cat config.mk