1 # Copyright 2013, 2014 Michael Forney
2 # Distributed under the terms of the GNU General Public License v2
8 DESCRIPTION
="WLD is a primitive drawing library targeted at Wayland"
9 HOMEPAGE
="https://github.com/michaelforney/wld"
10 EGIT_REPO_URI
="git://github.com/michaelforney/wld.git"
15 KEYWORDS
="~amd64 ~arm"
16 VIDEO_CARDS
="intel nouveau"
17 for card
in ${VIDEO_CARDS}; do
18 IUSE_VIDEO_CARDS
+=" video_cards_${card}"
20 IUSE
="${IUSE_VIDEO_CARDS} drm wayland"
24 >=media-libs/freetype-2.0.0
26 drm? ( x11-libs/libdrm[video_cards_intel?,video_cards_nouveau?] )
27 wayland? ( dev-libs/wayland )
33 local drm_drivers
=( ) wayland_interfaces
=( )
35 use video_cards_intel
&& drm_drivers
+=( intel
)
36 use video_cards_nouveau
&& drm_drivers
+=( nouveau
)
37 use drm
&& use wayland
&& wayland_interfaces
+=( drm
)
38 use wayland
&& wayland_interfaces
+=( shm
)
41 PREFIX = ${EPREFIX}/usr
42 LIBDIR = ${EPREFIX}/usr/$(get_libdir)
48 ENABLE_DRM = $(usex drm 1 0)
49 ENABLE_WAYLAND = $(usex wayland 1 0)
50 DRM_DRIVERS = ${drm_drivers[*]}
51 WAYLAND_INTERFACES = ${wayland_interfaces[*]}