dev-lua/lunix: update to actually support 5.4
[sgilles-overlay.git] / app-text / sile / sile-9999.ebuild
blobd69fce931c1a091d7d54660f46bff37dba60eecc
1 # Copyright 1999-2019 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 LUA_COMPAT=( lua5-{3..4} )
7 inherit autotools git-r3 lua-single
9 DESCRIPTION="Simon's Improved Layout Engine "
10 HOMEPAGE="http://sile-typesetter.org"
11 EGIT_REPO_URI="https://github.com/sile-typesetter/sile"
12 EGIT_SUBMODULES=()
14 if [[ ${PV} == 9999 ]]
15 then
17 else
18 EGIT_COMMIT="v${PV}"
21 LICENSE="MIT"
22 SLOT="0"
23 KEYWORDS="~amd64 ~arm ~hppa ~sparc ~x86"
25 RDEPEND="
26 dev-libs/libtexpdf
27 dev-lua/cassowary
28 dev-lua/cliargs
29 dev-lua/cosmo
30 dev-lua/epnf
31 dev-lua/linenoise
32 dev-lua/lpeg
33 dev-lua/luaexpat
34 dev-lua/luafilesystem
35 dev-lua/luasec
36 dev-lua/luasocket
37 dev-lua/lua-zlib
38 dev-lua/repl
39 dev-lua/stdlib
40 dev-lua/vstruct
43 src_prepare(){
44 default
45 rm -rf "${S}/libtexpdf"
46 eautoreconf
49 src_configure() {
50 ECONF_SOURCE="${S}" econf \
51 --with-system-expat \
52 --with-system-filesystem \
53 --with-system-libtexpdf \
54 --with-system-lpeg \
55 --with-system-luarocks \
56 --with-system-socket \
57 --with-system-zlib
60 src_install() {
61 emake DESTDIR="${D}" install