dev-lua/lunix: update to actually support 5.4
[sgilles-overlay.git] / dev-libs / libtexpdf / libtexpdf-0.0.20181005.ebuild
blob79ec3745eaba9a965594e3bee0bb996f0225a9f5
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit autotools git-r3 multilib-minimal
8 DESCRIPTION="PDF library extracted from TeX's dvipdfmx"
9 HOMEPAGE="http://sile-typesetter.org"
10 EGIT_REPO_URI="https://github.com/simoncozens/libtexpdf"
12 EGIT_COMMIT="50f0d788c358eb6e1953185f91817f885dc19649"
14 LICENSE="GPL-3"
15 SLOT="0"
16 KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86"
18 PATCHES=(
19 "${FILESDIR}/fix-fs-self-refs.patch"
22 src_prepare(){
23 default
24 eautoreconf
27 multilib_src_configure() {
28 ECONF_SOURCE="${S}" econf
31 multilib_src_install() {
32 emake DESTDIR="${D}" install