dev-lua/lunix: update to actually support 5.4
[sgilles-overlay.git] / media-fonts / tewi-font / tewi-font-9999.ebuild
blob9f13574f778826dff627f08ecfae6df9a6b985e1
1 EAPI=8
3 PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8,3_9,3_10} )
5 inherit font python-any-r1
7 DESCRIPTION="a bitmap font"
8 HOMEPAGE="https://github.com/lucy/tewi-font"
9 if [[ ${PV} != *9999* ]]; then
10 SRC_URI="https://github.com/lucy/tewi-font/archive/${PV}.tar.gz -> ${P}.tar.gz"
11 KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
12 else
13 EGIT_REPO_URI="https://github.com/lucy/tewi-font.git"
14 inherit git-r3
17 LICENSE="MIT"
18 SLOT="0"
20 IUSE="+pcf bdf"
22 RDEPEND=""
23 DEPEND="${PYTHON_DEPS}
24 pcf? ( x11-apps/bdftopcf )"
26 src_compile() {
27 if use pcf; then
28 emake
31 if use bdf; then
32 emake var
36 src_install() {
37 insinto "/usr/share/fonts/${PN}"
38 if use pcf; then
39 doins out/*
42 if use bdf; then
43 doins *.bdf
45 font_src_install