media-libs/libfec: correct license
[sgilles-overlay.git] / sci-mathematics / clav / clav-9999.ebuild
blobdb47d7c5ff0be26aa95cf08bf045979d82ec877e
1 # Copyright 2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit flag-o-matic git-r3
8 DESCRIPTION="Clav is a program to visualize cluster algebras as quivers"
9 HOMEPAGE="http://www.math.umd.edu/~sgilles"
10 EGIT_REPO_URI="https://repo.or.cz/clav.git"
11 if [[ ${PV} == 9999 ]]
12 then
13         :
14 else
15         EGIT_COMMIT="v${PV}"
16         KEYWORDS="alpha amd64 arm hppa ppc ppc64 sparc x86 amd64-fbsd x86-fbsd"
19 LICENSE="ISC"
20 SLOT="0"
21 IUSE="static"
22 LIB_DEPEND="
23         >=media-libs/sdl2-ttf-2.0.0[static-libs(+)]
24         media-libs/libsdl2[static-libs(+)]
25         media-fonts/dejavu"
26 RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
27 DEPEND="${RDEPEND}
28         static? ( ${LIB_DEPEND} )"
30 src_configure() {
31         use static && append-ldflags -static
32         default