1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
7 inherit eutils toolchain-funcs git-r3
9 DESCRIPTION
="MicroGnuEmacs, a port from the BSDs"
10 HOMEPAGE
="http://homepage.boetes.org/software/mg/"
11 EGIT_REPO_URI
="https://github.com/hboetes/mg.git"
12 EGIT_BRANCH
="display-wide-characters"
13 EGIT_COMMIT
="505b4aafd1efcf29dd5e3528cf46d1dbd6b75c57"
15 LICENSE
="public-domain"
17 KEYWORDS
="alpha amd64 arm hppa ppc ~ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
20 RDEPEND
="sys-libs/ncurses:0
21 !elibc_FreeBSD? ( >=dev-libs/libbsd-0.7.0 )"
28 # fix path to tutorial in man page
29 sed -i -e "s:doc/mg/:doc/${PF}/:" mg
.1 || die
31 #epatch "${FILESDIR}/${P}-missing-defines.patch"
35 emake CC
="$(tc-getCC)" \
37 CURSES_LIBS
="$("$
(tc-getPKG_CONFIG
)" --libs ncurses)"
44 # don't compress the tutorial, otherwise mg cannot open it
45 docompress
-x /usr
/share
/doc
/${PF}/tutorial
50 [[ -e ${EROOT}/usr
/bin
/emacs
]] ||
ln -s mg
"${EROOT}"/usr
/bin
/emacs