1 # Copyright 1999-2021 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
7 LUA_COMPAT=( lua5-{1..4} luajit )
11 DESCRIPTION="Pure Lua implementation of the wcwidth() function"
12 HOMEPAGE="https://github.com/aperezdc/lua-wcwidth"
13 EGIT_REPO_URI="https://github.com/aperezdc/lua-wcwidth"
14 if [[ ${PV} == 9999 ]]
23 KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
36 pushd "${BUILD_DIR}" || die
38 insinto "$(lua_get_lmod_dir)"
41 insinto "$(lua_get_lmod_dir)/wcwidth"
42 doins wcwidth/init.lua
43 doins wcwidth/widetab.lua
44 doins wcwidth/zerotab.lua
48 lua_foreach_impl lua_src_install