dev-lua/lua-spawn: bump to support lua 5.4
[sgilles-overlay.git] / dev-lua / wcwidth / wcwidth-0.2.ebuild
blob5b65ec891fbe6fb98cc6d5586cafa7ffcd5b1504
1 # Copyright 1999-2021 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
5 EAPI=8
7 LUA_COMPAT=( lua5-{1..4} luajit )
9 inherit lua git-r3
11 DESCRIPTION="Pure Lua implementation of the wcwidth() function"
12 HOMEPAGE="https://github.com/aperezdc/lua-wcwidth"
13 EGIT_REPO_URI="https://github.com/aperezdc/lua-wcwidth"
14 if [[ ${PV} == 9999 ]]
15 then
16         :
17 else
18         EGIT_COMMIT="v${PV}"
21 LICENSE="MIT"
22 SLOT="0"
23 KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
25 DEPEND="${LUA_DEPS}"
26 RDEPEND="${DEPEND}"
28 src_prepare() {
29         default
31         lua_copy_sources
35 lua_src_install() {
36         pushd "${BUILD_DIR}" || die
38         insinto "$(lua_get_lmod_dir)"
39         doins wcwidth.lua
40         
41         insinto "$(lua_get_lmod_dir)/wcwidth"
42         doins wcwidth/init.lua
43         doins wcwidth/widetab.lua
44         doins wcwidth/zerotab.lua
47 src_install() {
48         lua_foreach_impl lua_src_install