1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
5 inherit toolchain-funcs flag-o-matic eutils
7 DESCRIPTION="A utility to set the framebuffer videomode"
8 HOMEPAGE="http://users.telenet.be/geertu/Linux/fbdev/"
9 SRC_URI="http://users.telenet.be/geertu/Linux/fbdev/${P}.tar.gz"
13 KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sh sparc x86"
16 DEPEND="sys-devel/bison
21 "${FILESDIR}/${P}-build.patch"
22 "${FILESDIR}/${P}-__u32.patch"
26 use static && append-ldflags -static
28 emake || die "emake failed"
32 dobin fbset modeline2fb || die "dobin failed"
34 dodoc etc/fb.modes.* INSTALL