app-text/sile: restrict to lua 5.3+
[sgilles-overlay.git] / sys-apps / s6 / s6-2.3.0.0.ebuild
blob51c3fc2d08e20e66e627a64757403f97c9dc503e
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
5 EAPI=6
7 DESCRIPTION="skarnet.org's small and secure supervision software suite"
8 HOMEPAGE="http://www.skarnet.org/software/s6/"
9 SRC_URI="http://www.skarnet.org/software/${PN}/${P}.tar.gz"
11 LICENSE="ISC"
12 SLOT="0"
13 KEYWORDS="~amd64 ~x86"
14 IUSE="static static-libs"
16 DEPEND=">=sys-devel/make-4.0
17         static? (
18                 >=dev-lang/execline-2.1.4.5[static-libs]
19                 >=dev-libs/skalibs-2.3.9.0[static-libs]
20         )
21         !static? (
22                 >=dev-lang/execline-2.1.4.5
23                 >=dev-libs/skalibs-2.3.9.0
24         )
25         "
26 RDEPEND="
27         !static? (
28                 >=dev-lang/execline-2.1.4.5
29                 >=dev-libs/skalibs-2.3.9.0
30         )
31         "
33 DOCS="AUTHORS examples README*"
34 HTML_DOCS="doc/*"
36 src_prepare()
38         # Remove QA warning about LDFLAGS addition
39         sed -i "s~tryldflag LDFLAGS_AUTO -Wl,--hash-style=both~:~" "${S}/configure" || die
41         eapply_user
44 src_configure()
46         econf \
47                 $(use_enable !static shared) \
48                 $(use_enable static-libs static) \
49                 $(use_enable static allstatic) \
50                 --bindir=/bin \
51                 --sbindir=/sbin \
52                 --dynlibdir=/$(get_libdir) \
53                 --libdir=/usr/$(get_libdir)/${PN} \
54                 --datadir=/etc \
55                 --sysdepdir=/usr/$(get_libdir)/${PN} \
56                 --with-dynlib=/$(get_libdir) \
57                 --with-sysdeps=/usr/$(get_libdir)/skalibs