1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
8 inherit eutils multilib git-2 toolchain-funcs
11 HOMEPAGE="http://git.musl-libc.org/cgit/uuterm/"
12 EGIT_REPO_URI="git://git.musl-libc.org/uuterm"
18 KEYWORDS="~amd64 ~ppc ~x86"
21 RDEPEND="sys-libs/ncurses
22 X? ( x11-libs/libX11 )
23 !fbcon? ( x11-libs/libX11 )"
25 X? ( x11-proto/xproto )
26 !fbcon? ( x11-proto/xproto )"
32 myopt="${myopt} ucfcomp ytty/ytty.ucf uuterm-fb"
35 if use X || !use fbcon; then
39 emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${myopt} || die
46 if use X || !use fbcon; then
52 insinto /usr/share/${PN}/; doins ytty/ytty.ucf
54 doenvd "${FILESDIR}/99uuterm"
55 tic uuterm.ti -o "${D}/usr/share/terminfo"