app-text/sile: restrict to lua 5.3+
[sgilles-overlay.git] / x11-terms / uuterm / uuterm-9999.ebuild
blob47255a2849e79b23fd67ad594507c8142218a79f
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=5
8 inherit eutils multilib git-2 toolchain-funcs
10 DESCRIPTION="uuterm"
11 HOMEPAGE="http://git.musl-libc.org/cgit/uuterm/"
12 EGIT_REPO_URI="git://git.musl-libc.org/uuterm"
13 EGIT_PROJECT="uuterm"
14 SRC_URI=""
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~amd64 ~ppc ~x86"
19 IUSE="X fbcon"
21 RDEPEND="sys-libs/ncurses
22         X? ( x11-libs/libX11 )
23         !fbcon? ( x11-libs/libX11 )"
24 DEPEND="${RDEPEND}
25         X? ( x11-proto/xproto )
26         !fbcon? ( x11-proto/xproto )"
28 src_compile() {
29         local myopt
31         if use fbcon; then
32                 myopt="${myopt} ucfcomp ytty/ytty.ucf uuterm-fb"
33         fi
35         if use X || !use fbcon; then
36                 myopt="${myopt} all"
37         fi
39         emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${myopt} || die
42 src_install() {
43         if use fbcon;  then
44                 dobin uuterm-fb
45         fi
46         if use X || !use fbcon; then
47                 dobin uuterm-x11
48         fi
50         dobin ucfcomp
52         insinto /usr/share/${PN}/; doins ytty/ytty.ucf
54         doenvd "${FILESDIR}/99uuterm"
55         tic uuterm.ti -o "${D}/usr/share/terminfo"
57         dodoc README TODO