app-text/enchant: bump 2.3.1 -> 2.3.2
[sgilles-overlay.git] / media-sound / streamripper / streamripper-1.64.6.ebuild
blob68156abce4abdedc846ecf2bcd2781799c888d25
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/streamripper-1.64.6.ebuild,v 1.3 2012/05/05 08:53:54 mgorny Exp $
5 EAPI=2
7 inherit eutils
9 DESCRIPTION="Extracts and records individual MP3 file tracks from shoutcast streams"
10 HOMEPAGE="http://streamripper.sourceforge.net"
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
13 LICENSE="GPL-2"
14 SLOT="0"
15 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
16 IUSE="vorbis"
18 RDEPEND="media-libs/libmad
19         media-libs/faad2
20         >=dev-libs/glib-2.16
21         vorbis? ( media-libs/libvorbis )"
22 DEPEND="${RDEPEND}
23         virtual/pkgconfig"
25 src_configure() {
26         econf \
27                 --disable-dependency-tracking \
28                 --without-included-libmad \
29                 --without-included-argv \
30                 $(use_with vorbis ogg)
33 post_src_prepare() {
34                 epatch_user
37 src_install() {
38         emake DESTDIR="${D}" install || die
39         dodoc CHANGES parse_rules.txt README THANKS