1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
6 inherit eutils git-r3 multilib savedconfig toolchain-funcs
8 DESCRIPTION
="simple terminal implementation for Wayland"
9 HOMEPAGE
="http://st.suckless.org/"
10 EGIT_REPO_URI
="https://github.com/michaelforney/st.git"
13 LICENSE
="MIT-with-advertising"
18 !<sys-libs/ncurses-6.0
32 epatch
"${FILESDIR}/rename-with-wl-suffix.patch"
35 sed -e '/^CFLAGS/s:[[:space:]]-Wall[[:space:]]: :' \
36 -e '/^CFLAGS/s:[[:space:]]-O[^[:space:]]*[[:space:]]: :' \
37 -e '/^LDFLAGS/{s:[[:space:]]-s[[:space:]]: :}' \
38 -e '/^X11INC/{s:/usr/X11R6/include:/usr/include/X11:}' \
39 -e "/^X11LIB/{s:/usr/X11R6/lib:/usr/$(get_libdir)/X11:}" \
41 sed -e '/@echo/!s:@::' \
46 restore_config config.h
50 emake DESTDIR
="${D}" PREFIX
="${EPREFIX}"/usr
install
57 if ! [[ "${REPLACING_VERSIONS}" ]]; then
58 elog
"Please ensure a usable font is installed, like"
59 elog
" media-fonts/corefonts"
60 elog
" media-fonts/dejavu"
61 elog
" media-fonts/urw-fonts"