media-gfx/jpeg-xl: add plugin support
[sgilles-overlay.git] / sys-apps / s6-portable-utils / s6-portable-utils-2.0.6.0.ebuild
blobf08bdee70c73712ccbb3341f60f696711b4c9696
1 # Copyright 1999-2016 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
5 EAPI=6
7 inherit multilib
9 DESCRIPTION="Set of tiny portable unix utilities"
10 HOMEPAGE="http://www.skarnet.org/software/s6-portable-utils/"
11 SRC_URI="http://www.skarnet.org/software/${PN}/${P}.tar.gz"
13 LICENSE="ISC"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86 ~arm"
16 IUSE="static"
18 DEPEND="
19 static? ( >=dev-libs/skalibs-2.3.8.0[static-libs] )
20 !static? ( >=dev-libs/skalibs-2.3.8.0 )
22 RDEPEND="
23 !static? ( >=dev-libs/skalibs-2.3.8.0 )
26 HTML_DOCS="doc/."
28 src_prepare()
30 # Remove QA warning about LDFLAGS addition
31 sed -i "s~tryldflag LDFLAGS_AUTO -Wl,--hash-style=both~:~" "${S}/configure" || die
33 eapply_user
36 src_configure()
38 econf \
39 $(use_enable !static shared) \
40 $(use_enable static allstatic) \
41 $(use_enable static) \
42 --bindir=/bin \
43 --sbindir=/sbin \
44 --dynlibdir=/$(get_libdir) \
45 --libdir=/usr/$(get_libdir)/${PN} \
46 --datadir=/etc \
47 --sysdepdir=/usr/$(get_libdir)/${PN} \
48 --with-dynlib=/$(get_libdir) \
49 --with-sysdeps=/usr/$(get_libdir)/skalibs