inherit toolchain-funcs wherever tc-getCC present
[sgilles-overlay.git] / dev-lang / execline / execline-2.1.5.0.ebuild
blob155a8a92ec6dd08d14b64f407739cb9c4d123f41
1 # Copyright 2013-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
5 EAPI=6
7 inherit multilib
9 DESCRIPTION="a non-interactive scripting language similar to SH"
10 HOMEPAGE="http://www.skarnet.org/software/execline/"
11 SRC_URI="http://www.skarnet.org/software/${PN}/${P}.tar.gz"
13 LICENSE="ISC"
14 SLOT="0"
15 KEYWORDS="~amd64 ~x86"
16 IUSE="static static-libs"
18 DEPEND=">=sys-devel/make-4.0
19         static? ( >=dev-libs/skalibs-2.3.8.3[static-libs] )
20         !static? ( >=dev-libs/skalibs-2.3.8.3 )
22 RDEPEND="!static? ( >=dev-libs/skalibs-2.3.8.3 )"
24 src_prepare() {
25         # Remove QA warning about LDFLAGS addition
26         sed -i "s~tryldflag LDFLAGS_AUTO -Wl,--hash-style=both~:~" "${S}/configure" || die
28         eapply_user
31 src_configure()
33         econf \
34                 $(use_enable static-libs static) \
35                 $(use_enable static allstatic) \
36                 $(use_enable !static shared) \
37                 --bindir=/bin \
38                 --sbindir=/sbin \
39                 --dynlibdir=/$(get_libdir) \
40                 --libdir=/usr/$(get_libdir)/${PN} \
41                 --datadir=/etc \
42                 --sysdepdir=/usr/$(get_libdir)/${PN} \
43                 --with-dynlib=/$(get_libdir) \
44                 --with-lib=/usr/$(get_libdir)/skalibs \
45                 --with-sysdeps=/usr/$(get_libdir)/skalibs
48 src_compile()
50         emake DESTDIR="${D}"
53 src_install()
55         default
56         dohtml -r doc/*