1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/media-libs/sdl-ttf/sdl-ttf-2.0.11.ebuild,v 1.9 2012/06/08 19:38:07 mr_bones_ Exp $
6 inherit autotools eutils
9 DESCRIPTION="library that allows you to use TrueType fonts in SDL applications"
10 HOMEPAGE="http://www.libsdl.org/projects/SDL_ttf/"
11 SRC_URI="http://www.libsdl.org/projects/SDL_ttf/release/${MY_P}.tar.gz"
15 KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
18 DEPEND="X? ( x11-libs/libXt )
20 >=media-libs/freetype-2.3"
25 epatch "${FILESDIR}"/${P}-underlink.patch
26 epatch "${FILESDIR}"/${P}-fix-onscripter.patch
32 --disable-dependency-tracking \
33 $(use_enable static-libs static) \
38 emake DESTDIR="${D}" install || die
40 use static-libs || prune_libtool_files --all