app-editors/vis: remove savedconfig
[sgilles-overlay.git] / app-editors / vis / vis-9999.ebuild
blob40bdd080d5fb0cd3adf2dee7ef9c56174a455fee
1 EAPI=6
3 inherit eutils toolchain-funcs git-r3
5 DESCRIPTION="A vim-like text editor"
6 HOMEPAGE="http://repo.or.cz/vis.git"
7 EGIT_REPO_URI="https://repo.or.cz/vis.git"
8 if [[ ${PV} == 9999 ]]
9 then
11 else
12 EGIT_COMMIT="v${PV}"
15 LICENSE="ISC"
16 SLOT="0"
17 KEYWORDS="alpha amd64 arm hppa ppc ~ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
18 IUSE="lua syntax-highlighting"
19 REQUIRED_USE="syntax-highlighting? ( lua )"
21 RDEPEND="sys-libs/ncurses:0
22 dev-libs/libtermkey
23 lua? ( >=dev-lang/lua-5.2 )
24 syntax-highlighting? ( dev-lua/lpeg )"
25 DEPEND="${RDEPEND}
26 virtual/pkgconfig"
28 src_configure() {
29 econf $(use_enable lua)
31 # I'm not sure under what circumstances this works - just disable it.
32 sed -e 's/-Wl,-pie//g' -i config.mk