Fix : fix hot module under windows test. (at leat I hope...)
[shinken.git] / for_packages / python26-pyro.spec
blobb17993f2532b19d947eb42f0a770dacd1c48ac58
1 # release number:
2 %define rel %(date '+%Y%m%d%H%M')
4 %define pylibdir %{_libdir}/python2.6
6 %global __python /usr/bin/python26
8 Name: python26-pyro
9 URL: http://pyro.sourceforge.net/
10 Summary: PYthon Remote Objects
11 Version: 3.10
12 Release: %{rel}
13 License: MIT
14 Group: Development/Python
15 Source: http://downloads.sourceforge.net/pyro/Pyro-%{version}.tar.gz
16 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17 BuildArch: noarch
18 #%py_requires -d
20 %description
21 Pyro provides an object-oriented form of RPC. You can use Pyro within a
22 single system but also use it for IPC. For those that are familiar with
23 Java, Pyro resembles Java's Remote Method Invocation (RMI). It is less
24 similar to CORBA - which is a system- and language independent Distributed
25 Object Technology and has much more to offer than Pyro or RMI.
27 %prep
28 %setup -q -n Pyro-%{version}
30 %build
31 %{__python} setup.py build
33 %install
34 [ -d %{buildroot} -a "%{buildroot}" != "" ] && rm -rf %{buildroot}
35 echo n | %{__python} setup.py install --root=%{buildroot}
37 mkdir -p %{buildroot}%_bindir
38 install -m 0755 bin/* %{buildroot}%_bindir
40 %clean
41 [ -d %{buildroot} -a "%{buildroot}" != "" ] && rm -rf %{buildroot}
43 %files
44 %defattr(-,root,root)
45 %doc docs/* README.txt
46 %{_bindir}/*
47 %{pylibdir}/*
50 %changelog
51 * Tue Aug 03 2010 Stéphane Urbanovski <s.urbanovski@ac-nancy-metz.fr>
52 - update to 3.10 for RHEL5
53 - force python 2.6 usage
54 * Mon Jan 12 2009 Funda Wang <fundawang@mandriva.org> 3.8.1-1mdv2009.1
55 + Revision: 328584
56 - import python-pyro