Release 1.22.0 -- Application Sharing, Lync Autodiscover & Logging
[siplcs/bazlsi01.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blob2d9aa098d8ee6c38bbfc1666459bd67245d317c0
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
4 # It has support for:
6 # RedHat family (CentOS, Fedora, RHEL, ScientificLinux)
7 # SUSE family (openSUSE, SLED, SLES)
8 # Windows (mingw32, mingw64)
11 # Build options
12 %undefine build_telepathy
14 # Check for mingw32 cross compilation build
16 # Manually add this repository to your private OBS project:
18 # <repository name="mingw32">
19 # <path repository="openSUSE_13.2" project="windows:mingw:win32"/>
20 # <arch>i586</arch>
21 # </repository>
23 %if "%{_repository}" == "mingw32"
24 %define purple_sipe_mingw32 1
25 %define mingw_prefix mingw32-
26 %define mingw_cache %{_mingw32_cache}
27 %define mingw_configure %{_mingw32_configure}
28 %define mingw_datadir %{_mingw32_datadir}
29 %define mingw_debug_package %{_mingw32_debug_package}
30 %define mingw_ldflags MINGW32_LDFLAGS
31 %define mingw_libdir %{_mingw32_libdir}
32 %define mingw_make %{_mingw32_make}
33 %define mingw_makeinstall %{_mingw32_makeinstall}
34 %define __strip %{_mingw32_strip}
35 %define __objdump %{_mingw32_objdump}
36 %define _use_internal_dependency_generator 0
37 %define __find_requires %{_mingw32_findrequires}
38 %define __find_provides %{_mingw32_findprovides}
39 %define __os_install_post %{_mingw32_debug_install_post} \
40 %{_mingw32_install_post}
41 %endif
43 # Check for mingw64 cross compilation build
45 # Manually add this repository to your private OBS project:
47 # <repository name="mingw64">
48 # <path repository="openSUSE_13.2" project="windows:mingw:win64"/>
49 # <arch>i586</arch>
50 # </repository>
52 %if "%{_repository}" == "mingw64"
53 %define purple_sipe_mingw64 1
54 %define mingw_prefix mingw64-
55 %define mingw_cache %{_mingw64_cache}
56 %define mingw_configure %{_mingw64_configure}
57 %define mingw_datadir %{_mingw64_datadir}
58 %define mingw_debug_package %{_mingw64_debug_package}
59 %define mingw_ldflags MINGW64_LDFLAGS
60 %define mingw_libdir %{_mingw64_libdir}
61 %define mingw_make %{_mingw64_make}
62 %define mingw_makeinstall %{_mingw64_makeinstall}
63 %define __strip %{_mingw64_strip}
64 %define __objdump %{_mingw64_objdump}
65 %define _use_internal_dependency_generator 0
66 %define __find_requires %{_mingw64_findrequires}
67 %define __find_provides %{_mingw64_findprovides}
68 %define __os_install_post %{_mingw64_debug_install_post} \
69 %{_mingw64_install_post}
70 %endif
72 %define purple_plugin %{?mingw_prefix:%{mingw_prefix}}libpurple-plugin-sipe
73 %define telepathy_plugin %{?mingw_prefix:%{mingw_prefix}}telepathy-plugin-sipe
74 %define nsis_package %{?mingw_prefix:%{mingw_prefix}}pidgin-sipe-nsis
75 %define common_files sipe-common
76 %define empathy_files empathy-sipe
77 %define ktp_files ktp-accounts-kcm-sipe
80 %define has_pidgin 1
82 %if 0%{?suse_version}
83 %define nss_develname mozilla-nss-devel
84 # SLES11 defines suse_version = 1110
85 %if 0%{?suse_version} > 1110
86 %define has_appdata 1
87 %define has_libnice 1
88 %define has_gstreamer 1
89 %define build_telepathy 1
90 %define nice_gstreamer gstreamer-0_10-libnice
91 # Leap 42.1 or SLES12
92 %if 0%{?suse_version} >= 1315
93 %define has_gstreamer 0
94 %define has_gstreamer1 1
95 %define has_farstream 1
96 %undefine nice_gstreamer
97 %endif
98 %endif
99 %else
100 %define nss_develname nss-devel
101 %endif
103 %if 0%{?suse_version} || 0%{?sles_version}
104 %define pkg_group Productivity/Networking/Instant Messenger
105 %else
106 %define pkg_group Applications/Communications
107 %endif
109 %if 0%{?fedora}
110 %define has_libnice 1
111 %define has_gstreamer 1
112 %define build_telepathy 1
113 %define build_ktp 1
114 %if 0%{?fedora} >= 20
115 %define has_farstream 1
116 %define nice_gstreamer libnice-gstreamer
117 %if 0%{?fedora} >= 21
118 %define has_appdata 1
119 %define has_gssntlmssp 1
120 %if 0%{?fedora} >= 22
121 %define has_gstreamer 0
122 %define has_gstreamer1 1
123 %undefine nice_gstreamer
124 %endif
125 %endif
126 %endif
127 %endif
129 %if 0%{?centos_version} || 0%{?scientificlinux_version}
130 %define rhel_base_version %{?centos_version}%{?scientificlinux_version}
131 %if %{rhel_base_version} >= 600
132 %define has_gstreamer 1
133 %define has_libnice 1
134 %if %{rhel_base_version} >= 700
135 # pidgin has been removed, but libpurple still exists
136 %define has_pidgin 0
137 %endif
138 %endif
139 %endif
141 %if 0%{?purple_sipe_mingw32}
142 Name: mingw32-pidgin-sipe
143 %else
144 %if 0%{?purple_sipe_mingw64}
145 Name: mingw64-pidgin-sipe
146 %else
147 Name: pidgin-sipe
148 %endif
149 %endif
150 Summary: Pidgin protocol plugin to connect to MS Office Communicator
151 Version: 1.22.0
152 Release: 1
153 Source: pidgin-sipe-%{version}.tar.gz
154 Group: %{pkg_group}
155 License: GPLv2+
156 URL: http://sipe.sourceforge.net/
158 BuildRoot: %{_tmppath}/%{name}-%{version}-build
160 %if 0%{?mingw_prefix:1}
162 # Windows cross-compilation build setup
164 BuildArch: noarch
165 #!BuildIgnore: post-build-checks
167 BuildRequires: %{mingw_prefix}filesystem >= 23
168 BuildRequires: %{mingw_prefix}cross-gcc
169 BuildRequires: %{mingw_prefix}cross-binutils
170 BuildRequires: %{mingw_prefix}gettext-runtime
171 BuildRequires: %{mingw_prefix}cross-pkg-config
172 BuildRequires: %{mingw_prefix}glib2-devel >= 2.12.0
173 BuildRequires: %{mingw_prefix}libxml2-devel
174 BuildRequires: %{mingw_prefix}mozilla-nss-devel
175 BuildRequires: %{mingw_prefix}libpurple-devel >= 2.4.0
176 BuildRequires: %{mingw_prefix}cross-nsis
178 # For directory ownership
179 BuildRequires: %{mingw_prefix}pidgin
181 # Make sure telepathy is disabled for Windows builds
182 %undefine build_telepathy
184 %else
186 # Standard Linux build setup
188 BuildRequires: libpurple-devel >= 2.4.0
189 BuildRequires: libxml2-devel
190 BuildRequires: %{nss_develname}
191 BuildRequires: gettext-devel
192 # The following two are required to enable Voice & Video features
193 %if 0%{?has_libnice:1}
194 BuildRequires: libnice-devel
195 %if 0%{?nice_gstreamer:1}
196 # Dependency required when gstreamer support is split into two packages
197 Requires: %{nice_gstreamer}
198 %endif
199 %endif
200 %if 0%{?has_gstreamer:1}
201 BuildRequires: pkgconfig(gstreamer-0.10)
202 %endif
203 %if 0%{?has_gstreamer1:1}
204 BuildRequires: pkgconfig(gstreamer-1.0)
205 %endif
206 %if 0%{?has_farstream:1}
207 BuildRequires: pkgconfig(farstream-0.2)
208 BuildRequires: pkgconfig(gio-2.0)
209 %endif
210 # Requirements for telepathy backend
211 %if 0%{?build_telepathy:1}
212 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
213 BuildRequires: gmime-devel
214 BuildRequires: glib2-devel >= 2.28.0
215 %endif
217 # Configurable components
218 # Use "--without kerberos" to disable krb5
219 %if !0%{?_without_kerberos:1}
220 BuildRequires: krb5-devel
221 %if 0%{?has_gssntlmssp}
222 BuildRequires: gssntlmssp-devel >= 0.5.0
223 Requires: gssntlmssp >= 0.5.0
224 %endif
225 %endif
227 # For directory ownership
228 %if %{has_pidgin}
229 BuildRequires: pidgin
230 Requires: pidgin
231 %endif
232 %if 0%{?build_telepathy:1}
233 BuildRequires: empathy
234 %endif
236 # End Windows cross-compilation/Linux build setup
237 %endif
239 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
240 BuildRequires: libtool
241 BuildRequires: intltool
242 BuildRequires: glib2-devel >= 2.12.0
245 %description
246 A third-party plugin for the Pidgin multi-protocol instant messenger.
247 It implements the extended version of SIP/SIMPLE used by various products:
249 * Skype for Business
250 * Microsoft Office 365
251 * Microsoft Business Productivity Online Suite (BPOS)
252 * Microsoft Lync Server
253 * Microsoft Office Communications Server (OCS 2007/2007 R2)
254 * Microsoft Live Communications Server (LCS 2003/2005)
255 * Reuters Messaging
257 With this plugin you should be able to replace your Microsoft Office
258 Communicator client with Pidgin.
260 This package provides the icon set for Pidgin.
263 %package -n %{purple_plugin}
264 Summary: Libpurple protocol plugin to connect to MS Office Communicator
265 Group: %{pkg_group}
266 License: GPLv2+
267 Obsoletes: purple-sipe
268 %if 0%{?build_telepathy:1}
269 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
270 %endif
272 %description -n %{purple_plugin}
273 A third-party plugin for the Pidgin multi-protocol instant messenger.
274 It implements the extended version of SIP/SIMPLE used by various products:
276 * Skype for Business
277 * Microsoft Office 365
278 * Microsoft Business Productivity Online Suite (BPOS)
279 * Microsoft Lync Server
280 * Microsoft Office Communications Server (OCS 2007/2007 R2)
281 * Microsoft Live Communications Server (LCS 2003/2005)
282 * Reuters Messaging
284 This package provides the protocol plugin for libpurple clients.
287 %if 0%{?build_telepathy:1}
288 %package -n %{empathy_files}
289 Summary: Telepathy connection manager to connect to MS Office Communicator
290 Group: %{pkg_group}
291 License: GPLv2+
292 Requires: empathy
293 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
295 %description -n %{empathy_files}
296 A Telepathy connection manager that implements the extended version of
297 SIP/SIMPLE used by various products:
299 * Skype for Business
300 * Microsoft Office 365
301 * Microsoft Business Productivity Online Suite (BPOS)
302 * Microsoft Lync Server
303 * Microsoft Office Communications Server (OCS 2007/2007 R2)
304 * Microsoft Live Communications Server (LCS 2003/2005)
305 * Reuters Messaging
307 This package provides the icon set for Empathy.
310 %if 0%{?build_ktp:1}
311 %package -n %{ktp_files}
312 Summary: Telepathy connection manager to connect to MS Office Communicator
313 Group: %{pkg_group}
314 License: GPLv2+
315 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
317 %description -n %{ktp_files}
318 A Telepathy connection manager that implements the extended version of
319 SIP/SIMPLE used by various products:
321 * Skype for Business
322 * Microsoft Office 365
323 * Microsoft Business Productivity Online Suite (BPOS)
324 * Microsoft Lync Server
325 * Microsoft Office Communications Server (OCS 2007/2007 R2)
326 * Microsoft Live Communications Server (LCS 2003/2005)
327 * Reuters Messaging
329 This package provides the profile for KTP account manager.
330 %endif
333 %package -n %{telepathy_plugin}
334 Summary: Telepathy connection manager to connect to MS Office Communicator
335 Group: %{pkg_group}
336 License: GPLv2+
337 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
339 %description -n %{telepathy_plugin}
340 A Telepathy connection manager that implements the extended version of
341 SIP/SIMPLE used by various products:
343 * Skype for Business
344 * Microsoft Office 365
345 * Microsoft Business Productivity Online Suite (BPOS)
346 * Microsoft Lync Server
347 * Microsoft Office Communications Server (OCS 2007/2007 R2)
348 * Microsoft Live Communications Server (LCS 2003/2005)
349 * Reuters Messaging
351 This package provides the protocol support for Telepathy clients.
354 %package -n %{common_files}
355 Summary: Common files for SIPE protocol plugins
356 Group: %{pkg_group}
357 License: GPLv2+
358 BuildArch: noarch
360 %description -n %{common_files}
361 This package provides common files for the SIPE protocol plugins:
363 * Localisation
364 %endif
367 %if 0%{?mingw_prefix:1}
368 %package -n %{nsis_package}
369 Summary: Windows Pidgin protocol plugin to connect to MS Office Communicator
370 Group: %{pkg_group}
371 License: GPLv2+
373 %description -n %{nsis_package}
374 A third-party plugin for the Pidgin multi-protocol instant messenger.
375 It implements the extended version of SIP/SIMPLE used by various products:
377 * Skype for Business
378 * Microsoft Office 365
379 * Microsoft Business Productivity Online Suite (BPOS)
380 * Microsoft Lync Server
381 * Microsoft Office Communications Server (OCS 2007/2007 R2)
382 * Microsoft Live Communications Server (LCS 2003/2005)
383 * Reuters Messaging
385 This package contains the NSIS installer package of the protocol plugin
386 for Pidgin on Windows.
387 %endif
390 %{mingw_debug_package}
393 %prep
394 %setup -q -n pidgin-sipe-%{version}
396 %build
397 %if 0%{?mingw_prefix:1}
399 # Windows cross-compilation build
401 %{?env_options}
402 echo "lt_cv_deplibs_check_method='pass_all'" >>%{mingw_cache}
403 autoreconf --verbose --install --force
404 %{mingw_ldflags}="-Wl,--exclude-libs=libintl.a -Wl,--exclude-libs=libiconv.a -lws2_32"
405 %{mingw_configure} \
406 --enable-purple \
407 %if 0%{?build_telepathy:1}
408 --enable-telepathy
409 %else
410 --disable-telepathy
411 %endif
412 %{mingw_make} %{?_smp_mflags} || %{mingw_make}
414 %else
416 # Standard Linux build
418 %configure \
419 %if !0%{?_without_kerberos:1}
420 --with-krb5 \
421 %endif
422 --enable-purple \
423 %if 0%{?build_telepathy:1}
424 --enable-telepathy
425 %else
426 --disable-telepathy
427 %endif
428 make %{?_smp_mflags}
429 make %{?_smp_mflags} check
431 # End Windows cross-compilation/Linux build setup
432 %endif
435 %install
436 %if 0%{?mingw_prefix:1}
438 # Windows cross-compilation install
440 %{mingw_makeinstall}
441 rm -f %{buildroot}%{mingw_libdir}/purple-2/*.dll.a
443 # generate .dbgsym file
444 rm -f %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym
445 mv \
446 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll \
447 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym
448 %{__strip} --strip-unneeded \
449 %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll.dbgsym \
450 -o %{buildroot}%{mingw_libdir}/purple-2/libsipe.dll \
452 # generate NSIS installer package
453 perl contrib/opensuse-build-service/generate_nsi.pl po/LINGUAS \
454 <contrib/opensuse-build-service/pidgin-sipe.nsi.template \
455 >%{buildroot}/pidgin-sipe.nsi
457 set -e; \
458 cd %{buildroot}; \
459 makensis \
460 -DPIDGIN_VERSION=UNKNOWN \
461 -DVERSION=%{version} \
462 -DMINGW_LIBDIR=%{buildroot}%{mingw_libdir} \
463 -DMINGW_DATADIR=%{buildroot}%{mingw_datadir} \
464 pidgin-sipe.nsi \
466 rm -f %{buildroot}/pidgin-sipe.nsi
468 %else
470 # Standard Linux install
472 %makeinstall
474 # End Windows cross-compilation/Linux build setup
475 %endif
477 find %{buildroot} -type f -name "*.la" -delete -print
478 # SLES11 defines suse_version = 1110
479 %if 0%{?suse_version} && 0%{?suse_version} < 1120
480 rm -r %{buildroot}/%{_datadir}/pixmaps/pidgin/protocols/scalable
481 %endif
482 # Pidgin doesn't have 24 or 32 pixel icons
483 rm -f \
484 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
485 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
486 %if !0%{?has_appdata:1}
487 # We don't have AppStream, so we can't package metadata file at all
488 rm -r %{buildroot}/%{_datadir}/appdata
489 %endif
490 %if !%{has_pidgin}
491 # We don't have Pidgin, so we can't package icons at all
492 rm -r %{buildroot}/%{_datadir}/pixmaps/pidgin
493 %endif
494 %if 0%{?build_telepathy:1}
495 %if !0%{?build_ktp:1}
496 rm -r %{buildroot}%{_datadir}/telepathy
497 %endif
498 %endif
499 %find_lang pidgin-sipe
502 %clean
503 rm -rf %{buildroot}
506 %if 0%{?build_telepathy:1}
507 %files -n %{purple_plugin}
508 %else
509 %files -n %{purple_plugin} -f pidgin-sipe.lang
510 %endif
511 %defattr(-,root,root,-)
512 %doc AUTHORS ChangeLog COPYING NEWS README TODO
513 %if 0%{?mingw_prefix:1}
514 %{mingw_libdir}/purple-2/libsipe.dll
515 %{mingw_libdir}/purple-2/libsipe.dll.dbgsym
516 %else
517 %{_libdir}/purple-2/libsipe.so
518 %endif
521 %if 0%{?build_telepathy:1}
522 %files -n %{empathy_files}
523 %defattr(-,root,root,-)
524 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
525 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
528 %if 0%{?build_ktp:1}
529 %files -n %{ktp_files}
530 %defattr(-,root,root,-)
531 %doc AUTHORS COPYING
532 %{_datadir}/telepathy/profiles/sipe.profile
533 %endif
536 %files -n %{telepathy_plugin}
537 %defattr(-,root,root,-)
538 %doc AUTHORS ChangeLog COPYING NEWS README TODO
539 %{_datadir}/dbus-1/services/*.sipe.service
540 %{_libexecdir}/telepathy-sipe
543 %files -n %{common_files} -f pidgin-sipe.lang
544 %defattr(-,root,root,-)
545 %endif
548 %files
549 %defattr(-,root,root,-)
550 %doc AUTHORS COPYING
551 %if 0%{?mingw_prefix:1}
552 %if 0%{?has_appdata:1}
553 %{mingw_datadir}/appdata/pidgin-sipe.metainfo.xml
554 %endif
555 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.png
556 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
557 %else
558 %if %{has_pidgin}
559 %if 0%{?has_appdata:1}
560 %{_datadir}/appdata/%{name}.metainfo.xml
561 %endif
562 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
563 # SLES11 defines suse_version = 1110
564 %if !0%{?suse_version} || 0%{?suse_version} >= 1120
565 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
566 %endif
567 %endif
568 %endif
571 %if 0%{?mingw_prefix:1}
572 %files -n %{nsis_package}
573 %defattr(-, root, root)
574 /pidgin-sipe-%{version}.exe
575 %endif
578 %changelog
579 * Wed Feb 01 2017 J. D. User <jduser@noreply.com> 1.22.0
580 - update to 1.22.0
582 * Sun Dec 18 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
583 - add BR gio-2.0
585 * Wed Jun 15 2016 J. D. User <jduser@noreply.com> 1.21.1-*git*
586 - add BR farstream-0.2
588 * Sat May 28 2016 J. D. User <jduser@noreply.com> 1.21.1
589 - update to 1.21.1
591 * Sat Apr 23 2016 J. D. User <jduser@noreply.com> 1.21.0
592 - update to 1.21.0
594 * Tue Apr 05 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
595 - align with Fedora SPEC file
597 * Fri Jan 01 2016 J. D. User <jduser@noreply.com> 1.20.1-*git*
598 - add AppStream metadata file
600 * Sun Nov 08 2015 J. D. User <jduser@noreply.com> 1.20.1-*git*
601 - add dependency on pkgconfig(gstreamer-1.0) for F22+ & Leap 42.1+
603 * Sat Oct 24 2015 J. D. User <jduser@noreply.com> 1.20.1
604 - update to 1.20.1
606 * Thu Sep 03 2015 J. D. User <jduser@noreply.com> 1.20.0-*git*
607 - we also support "Skype for Business"
609 * Sat Aug 29 2015 J. D. User <jduser@noreply.com> 1.20.0
610 - update to 1.20.0
612 * Sat Apr 04 2015 J. D. User <jduser@noreply.com> 1.19.1
613 - update to 1.19.1
615 * Sat Feb 07 2015 J. D. User <jduser@noreply.com> 1.19.0
616 - update to 1.19.0
618 * Tue Jan 06 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
619 - add dependency on gssntlmssp(-devel) >= 0.5.0 for F21+
621 * Mon Jan 05 2015 J. D. User <jduser@noreply.com> 1.18.5-*git*
622 - remove support for obsolete distributions
623 - Fedora < 19
624 - Mandriva
625 - OpenSUSE < 13.x
627 * Mon Dec 29 2014 J. D. User <jduser@noreply.com> 1.18.5
628 - update to 1.18.5
630 * Thu Dec 18 2014 J. D. User <jduser@noreply.com> 1.18.4-*git*
631 - improve support for CentOS & Scientific Linux
633 * Sat Oct 18 2014 J. D. User <jduser@noreply.com> 1.18.4
634 - update to 1.18.4
636 * Sat Aug 16 2014 J. D. User <jduser@noreply.com> 1.18.3
637 - update to 1.18.3
639 * Sat Jun 07 2014 J. D. User <jduser@noreply.com> 1.18.2
640 - update to 1.18.2
642 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
643 - update to 1.18.1
645 * Tue Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
646 - F20+/openSUSE 12.2+ require libnice gstreamer-0.10 plugin
648 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
649 - update to 1.18.0
651 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
652 - update to 1.17.3
654 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
655 - update to 1.17.2
657 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
658 - update to 1.17.1
660 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
661 - update to 1.17.0
663 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
664 - update to 1.16.1
666 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
667 - update to 1.16.0
669 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
670 - update to 1.15.1
672 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
673 - update package description texts
675 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
676 - update to 1.15.0
678 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
679 - update to 1.14.1
681 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
682 - update to 1.14.0
684 * Tue Sep 25 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
685 - change BR gstreamer-devel to pkgconfig(gstreamer-0.10)
687 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
688 - BR telepathy-glib-devel >= 0.18.0
690 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
691 - BR telepathy-glib-devel >= 0.14.0
693 * Sun Sep 02 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
694 - really disable telepathy for Windows cross-compilation builds
696 * Thu Aug 30 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
697 - updates to enable telepathy build
699 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
700 - update to 1.13.3
702 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
703 - update to 1.13.2
705 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
706 - update to 1.13.1
708 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
709 - update to 1.13.0
711 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
712 - we do support Microsoft Lync Server 2010 now.
714 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
715 - update GPL2 license name
717 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
718 - add BR gmime-devel for Fedora to have at least one verification platform
720 * Sun Nov 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
721 - fix Mandriva 2011 unresolvable BR
723 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
724 - add BR nss-devel
726 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
727 - add NSIS package for mingw builds
729 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
730 - add mingw64 build
732 * Wed Sep 28 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
733 - remove BR mingw32-mozilla-nss-devel, not needed for SSPI.
735 * Mon Sep 19 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
736 - update mingw32 build
737 - update descriptions
739 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
740 - update to 1.12.0
742 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
743 - add gstreamer-devel to enable Voice & Video features
745 * Sat Dec 11 2010 J. D. User <jduser@noreply.com> 1.11.2-*git*
746 - add optional subpackage for telepathy connection manager
748 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
749 - update to 1.11.2
751 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
752 - update to 1.11.1
754 * Fri Oct 15 2010 J. D. User <jduser@noreply.com> 1.11.0-*git*
755 - add mingw32 build configuration
757 * Sun Oct 03 2010 J. D. User <jduser@noreply.com> 1.11.0
758 - update to 1.11.0
760 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> pre-1.11.0-*git*
761 - Mandriva config for OBS has changed
763 * Tue May 04 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
764 - add libnice build information discovered through OBS testing
766 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
767 - add NSS build information discovered through OBS testing
769 * Sun Apr 04 2010 pier11 <pier11@operamail.com> 1.10.0
770 - release
772 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
773 - Mandriva has too old libtool version
775 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
776 - SLE11, openSUSE 11.0/1 don't have pidgin/protocols/scalable directory
778 * Thu Apr 01 2010 pier11 <pier11@operamail.com> pre-1.10.0-*git*
779 - OBS tests of pre-1.10.0 git-snapshot 4fa20cd65e5be0e469d4aa55d861f11c5b08b816
781 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
782 - added --enable/--disable build options
784 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
785 - removed --with-krb5 configure option as it is autodetected now
787 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
788 - add SVG icon
790 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
791 - add BR glib2-devel >= 2.12.0
793 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
794 - add tests to build
796 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
797 - update to 1.9.1
799 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
800 - add BR libxml2-devel
802 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
803 - release
804 - dropped SLE 10 due to libpurple min version increase
805 - updated target distros in comment line
807 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
808 - increased libpurple build requisite to >= 2.4.0
810 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
811 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
813 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
814 - sync with RPM SPEC from contrib/rpm
816 * Mon Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
817 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
818 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
820 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
821 - reinstated enable-quality-check
823 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
824 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
826 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
827 - Spec file modifications for openSUSE build service
829 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
830 - move non-Pidgin files to new sub-package purple-sipe
832 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
833 - remove directory for emoticon theme icons
835 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
836 - libpurple protocol plugins are located under %%{_libdir}/purple-2
838 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
839 - added directory for emoticon theme icons
841 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
842 - update to 1.6.3
844 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
845 - reduce libpurple-devel requirement to >= 2.3.1
847 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
848 - update to 1.6.2
850 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
851 - reduce libpurple-devel requirement to >= 2.4.1
853 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
854 - com_err.h only required for kerberos
856 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
857 - require libpurple-devel >= 2.5.0
859 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
860 - refactor configure parameters
861 - make kerberos configurable
862 - don't hard code prefix for git builds
864 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
865 - removed unnecessary zlib-devel
867 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
868 - fix prefix for git builds
870 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
871 - append -Wno-unused-parameter for GCC <4.4 compilation errors
873 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
874 - remove duplicate GPL2
876 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
877 - use "--with git" to build from git
878 - corrected download URL for release archive
879 - add missing BR gettext-devel
881 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
882 - use default rpmbuild CFLAGS also for git builds
883 - merge with SPEC files created by mricon & jberanek
885 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
886 - initial RPM SPEC example generated