3 # Slackware build script for xautolock
5 # Bruce Forte revision date 2017/01/19
8 # Redistribution and use of this script, with or without modification, is
9 # permitted provided that the following conditions are met:
11 # 1. Redistributions of this script must retain the above copyright
12 # notice, this list of conditions and the following disclaimer.
14 # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
15 # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
16 # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
17 # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
18 # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
19 # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
20 # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
21 # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
22 # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
23 # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
25 cd $
(dirname $0) ; CWD
=$
(pwd)
28 VERSION
=${VERSION:-2.2}
31 PKGTYPE
=${PKGTYPE:-tgz}
33 if [ -z "$ARCH" ]; then
34 case "$( uname -m )" in
37 *) ARCH
=$
( uname
-m ) ;;
41 # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
42 # the name of the created package would be, and then exit. This information
43 # could be useful to other scripts.
44 if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
45 echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
50 PKG
=$TMP/package-
$PRGNAM
51 OUTPUT
=${OUTPUT:-/tmp}
53 if [ "$ARCH" = "i586" ]; then
54 SLKCFLAGS
="-O2 -march=i586 -mtune=i686"
56 elif [ "$ARCH" = "i686" ]; then
57 SLKCFLAGS
="-O2 -march=i686 -mtune=i686"
59 elif [ "$ARCH" = "x86_64" ]; then
70 mkdir
-p $TMP $PKG $OUTPUT
72 rm -rf $PRGNAM-$VERSION
73 tar xvf
$CWD/$PRGNAM-$VERSION.tgz
77 \
( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
78 -o -perm 511 \
) -exec chmod 755 {} \
; -o \
79 \
( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
80 -o -perm 440 -o -perm 400 \
) -exec chmod 644 {} \
;
82 # Quick work-around for slackware-current
83 sed -i 's/union\ wait\ \ status/int\ status\ \=\ 0/g' src
/engine.c
87 make install DESTDIR
=$PKG
88 make install.man DESTDIR
=$PKG
90 find $PKG -print0 |
xargs -0 file |
grep -e "executable" -e "shared object" |
grep ELF \
91 | cut
-f 1 -d : |
xargs strip
--strip-unneeded 2> /dev
/null || true
93 mkdir
-p $PKG/usr
/doc
/$PRGNAM-$VERSION
94 cp -a Changelog License Readme Todo
$PKG/usr
/doc
/$PRGNAM-$VERSION
95 cat $CWD/$PRGNAM.SlackBuild
> $PKG/usr
/doc
/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
96 gzip -9 $PKG/usr
/man
/man
1/xautolock
.1x
99 cat $CWD/slack-desc
> $PKG/install
/slack-desc
102 /sbin
/makepkg
-l y
-c n
$OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.
$PKGTYPE