Fix compiler warning due to missing function prototype.
[svn.git] / packages / rpm / redhat-8+ / subversion.spec
blobc30ceeb93b1ec60eebdc909aacc4ac713d24c423
1 %define apache_version 2.0.48-0.1
2 %define apr_version 0.9.7
3 %define neon_version 0.26.1
4 %define swig_version 1.3.25
5 %define apache_dir /usr
6 %define pyver 2.2
7 # If you don't want to take time for the tests then set make_*_check to 0.
8 %define make_ra_local_bdb_check 1
9 %define make_ra_svn_bdb_check 1
10 %define make_ra_dav_bdb_check 1
11 %define make_ra_local_fsfs_check 1
12 %define make_ra_svn_fsfs_check 1
13 %define make_ra_dav_fsfs_check 1
14 Summary: A Concurrent Versioning system similar to but better than CVS.
15 Name: subversion
16 Version: @VERSION@
17 Release: @RELEASE@
18 Copyright: BSD
19 Group: Utilities/System
20 URL: http://subversion.tigris.org
21 SOURCE0: subversion-%{version}-%{release}.tar.gz
22 SOURCE3: filter-requires.sh
23 Patch1: subversion-0.31.0-rpath.patch
24 Vendor: Summersoft
25 Packager: David Summers <david@summersoft.fay.ar.us>
26 Requires: apr >= %{apr_version}
27 Requires: apr-util >= %{apr_version}
28 Requires: db4 >= 4.0.14
29 Requires: neon >= %{neon_version}
30 BuildPreReq: autoconf >= 2.53
31 BuildPreReq: db4-devel >= 4.0.14
32 BuildPreReq: docbook-style-xsl >= 1.58.1
33 BuildPreReq: doxygen
34 BuildPreReq: expat-devel
35 BuildPreReq: gettext
36 BuildPreReq: httpd >= %{apache_version}
37 BuildPreReq: apr-devel >= %{apr_version}
38 BuildPreReq: apr-util-devel >= %{apr_version}
39 BuildPreReq: libtool >= 1.4.2
40 BuildPreReq: libxslt >= 1.0.27
41 BuildPreReq: neon-devel >= %{neon_version}
42 BuildPreReq: openssl-devel
43 BuildPreReq: perl >= 5.8.0-88
44 BuildPreReq: python
45 BuildPreReq: python-devel
46 BuildPreReq: swig >= %{swig_version}
47 BuildPreReq: zlib-devel
48 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
49 Prefix: /usr
50 %description
51 Subversion is a concurrent version control system which enables one or more
52 users to collaborate in developing and maintaining a hierarchy of files and
53 directories while keeping a history of all changes. Subversion only stores
54 the differences between versions, instead of every complete file. Subversion
55 also keeps a log of who, when, and why changes occurred.
57 As such it basically does the same thing CVS does (Concurrent Versioning System)
58 but has major enhancements compared to CVS and fixes a lot of the annoyances
59 that CVS users face.
61 *** Note: This is a relocatable package; it can be installed anywhere you like
62 with the "rpm -Uvh --prefix /your/favorite/path" command. This is useful
63 if you don't have root access on your machine but would like to use this
64 package.
66 %package devel
67 Group: Utilities/System
68 Summary: Development package for Subversion developers.
69 Requires: subversion = %{version}-%{release}
70 %description devel
71 The subversion-devel package includes the static libraries and include files
72 for developers interacting with the subversion package.
74 %package server
75 Group: Utilities/System
76 Summary: Apache server module for Subversion server.
77 Requires: apr >= %{apr_version}
78 Requires: apr-util >= %{apr_version}
79 Requires: subversion = %{version}-%{release}
80 Requires: httpd >= %{apache_version}
81 BuildPreReq: httpd-devel >= %{apache_version}
82 %description server
83 The subversion-server package adds the Subversion server Apache module to
84 the Apache directories and configuration.
86 %package perl
87 Group: Utilities/System
88 Summary: Allows Perl scripts to directly use Subversion repositories.
89 Requires: perl
90 %description perl
91 Provides Perl (SWIG) support for Subversion.
93 %package python
94 Group: Utilities/System
95 Summary: Allows Python scripts to directly use Subversion repositories.
96 Requires: python >= 2
97 %description python
98 Provides Python (SWIG) support for Subversion.
100 %package tools
101 Group: Utilities/System
102 Summary: Tools for Subversion
103 %description tools
104 Tools for Subversion.
106 %changelog
107 * Sat Jun 30 2007 David Summers <david@summersoft.fay.ar.us> r27438
108 - [RHEL5] Added neon-0.26.1 requirement.
110 * Sat Jun 30 2007 David Summers <david@summersoft.fay.ar.us> r25592
111 - [RHEL5] Added RHEL5 SPEC file.
113 * Fri Jul 07 2006 David Summers <david@summersoft.fay.ar.us> r20468
114 - [RH8,RH9,RHEL3,RHEL4] Updated to APR/APR-UTIL 0.9.12.
115 RHEL3 requires httpd-2.0.46-56.ent.centos.2.1 or higher which includes
116 APR/APR-UTIL 0.9.12.
118 * Mon Jun 26 2006 David Summers <david@summersoft.fay.ar.us> r20253
119 - [RHEL3,RHEL4] Follow-up to r20040, changed %{apache_dir} to %{_libdir}
120 and %{_prefix} to %{_libdir} to help out people compiling 64-bit versions.
121 Thanks to Toby Johnson and others.
123 * Sun Jun 11 2006 David Summers <david@summersoft.fay.ar.us> r20040
124 - Figured out another (better) way to fix Subversion bug #1456 instead of
125 depending on a third program (chrpath); Used Fedora Core RPATH patch to
126 change the build procedure to eliminate the wierd RPATH in the Subversion
127 Apache modules.
129 * Sat Jun 10 2006 David Summers <david@summersoft.fay.ar.us> r20038
130 - Changed /usr/lib to %{_libdir} and /usr/bin to %{_bindir} to help out
131 people compiling 64-bit versions. More needs to be done.
133 * Mon Mar 20 2006 David Summers <david@summersoft.fay.ar.us> r18962
134 - Added needed 'gettext' BuildPreReq.
135 Thanks go to Francis Giraldeau <francis.giraldeau@revolutionlinux.com>.
137 * Sat Jan 07 2006 David Summers <david@summersoft.fay.ar.us> r18013
138 - Simplify apache regression testing.
140 * Sat Dec 17 2005 David Summers <david@summersoft.fay.ar.us> r17832
141 - Figured out how to disable module configuration with --disable-mod-activation.
143 * Sat Dec 17 2005 David Summers <david@summersoft.fay.ar.us> r17828
144 - Fixed Subversion bug # 1456: Subversion RedHat RPMs have bad interaction with
145 NFS server/client.
147 * Sat Sep 24 2005 David Summers <david@summersoft.fay.ar.us> r16237
148 - [RHL8, RHL9] Updated to swig 1.3.25 to get rid of run-time dependencies on
149 swig package. With this update, only the developer/packager needs to install
150 swig.
152 * Sat Sep 24 2005 David Summers <david@summersoft.fay.ar.us> r16236
153 - [RHL7] Update do swig-1.3.25. This makes it so that only the
154 packager/developer needs to install the swig package.
156 * Fri Sep 23 2005 David Summers <david@summersoft.fay.ar.us> r16222
157 - [RHEL3] Update to SWIG 1.3.25. This makes it so that only the
158 developer/packager needs the SWIG package installed.
160 * Wed Aug 31 2005 David Summers <david@summersoft.fay.ar.us> r16011
161 - [RHEL4] Update to SWIG 1.3.25. This makes it so that only the
162 developer/packager needs the SWIG package installed.
164 * Sun Aug 07 2005 David Summers <david@summersoft.fay.ar.us> r15615
165 - [RHEL4] Fix bug where RHEL4 version can't find Python bindings.
166 RHEL4 uses python 2.3 instead of python 2.2.
168 * Mon Jun 13 2005 David Summers <david@summersoft.fay.ar.us> r15049
169 - [RHL7, RHL8, RHL9] Fix breakage that *only* occurs during release build
170 (noticed on 1.2.0).
172 * Sat Apr 30 2005 David Summers <david@summersoft.fay.ar.us> r14530
173 - [!RHEL3] Make backend regression tests explicit and make sure we do them for
174 both BDB and FSFS backends.
176 * Sun Apr 24 2005 David Summers <david@summersoft.fay.ar.us> r14429
177 - [RHEL4] Add build for RHEL4 for both BDB and FSFS back-ends.
179 * Sun Apr 17 2005 David Summers <david@summersoft.fay.ar.us> r14276
180 - [RHEL3] *** WARNING: This version drops support for Berkeley BDB.
182 *** WARNING ***: If you have previously used the Berkeley BDB back-end
183 you must do a svnadmin dump BEFORE installing this package and a svnadmin
184 load AFTER installing it. I'm hoping this will be not be too much of a
185 hassle because to implement the new subversion 1.2 xdelta compression you
186 will need to do a dump/load anyway.
188 *** Note: This is not a requirement/problem of Subversion but of my previous
189 subversion packages where I tried to back-port/forward-port required packages
190 that came with the distribution.
192 - [RHEL3] Finally gave up trying to integrate manually with forward ported and
193 back ported packages. There are just too many interdependencies between
194 APR, BDB, APACHE, PHP, etc.
196 - [RHEL3] Changed subversion-server package name to mod_dav_svn.
198 * Thu Mar 31 2005 David Summers <david@summersoft.fay.ar.us> r13821
199 - Greatly reduce disk usage by telling each test pass to cleanup after
200 successful tests.
202 * Sun Mar 27 2005 David Summers <david@summersoft.fay.ar.us> r13716
203 - [RHL7] Fixed dependencies to use libtool and autoconf253 that already comes
204 with RedHat 7.3. I obviously didn't do my homework a couple of years ago.
205 No need to support updated/custom versions of these.
207 * Sun Mar 27 2005 David Summers <david@summersoft.fay.ar.us> r13714
208 - Make use of the new swig-1.3.19-3 package which allows swig-1.3.19 to
209 co-exist with the swig-1.1p5 package that comes with Redhat.
211 * Sun Mar 27 2005 David Summers <david@summersoft.fay.ar.us> r13711
212 - Take out "static build" feature that never actually worked as intended.
214 * Sun Mar 27 2005 David Summers <david@summersoft.fay.ar.us> r13709
215 - Fix http tests to work with new locking feature which now requires
216 authentication.
218 * Tue Mar 15 2005 David Summers <david@summersoft.fay.ar.us> r13417
219 - Supplementary: Take out documentation patch altogether.
220 - [RHEL3, RHEL4] Turn testing back on, it was accidentally turned off.
222 * Sun Jan 09 2005 David Summers <david@summersoft.fay.ar.us> r13202
223 - Bye bye book; it is now no longer a part of the Subversion repository but
224 is at the http://svn.red-bean.com/svnbook/ URL.
225 I will probably create a separate RPM package for it now...stay tuned.
227 * Sun Jan 09 2005 David Summers <david@summersoft.fay.ar.us> 1.1.2-12650
228 - Delete apr, apr-util, and neon from the distribution tree as those
229 packages are already installed.
231 * Wed Dec 29 2004 David Summers <david@summersoft.fay.ar.us> 1.1.2-12531
232 - Added "noreplace" option to subversion.conf to not replace it if it has
233 been changed. This (hopefully) prevents the server from failing when doing
234 an upgrade. Thanks to Peter Holzleitner for the suggestion.
236 * Wed Jul 07 2004 David Summers <david@summersoft.fay.ar.us> 1.1.0-10174
237 - Require neon-0.24.7 to fix invalid XML (compression) bug.
239 * Thu May 20 2004 Ben Reser <ben@reser.org> 1.1.0-9807
240 - [RHL7, RHL8, RHL9] Require neon 0.24.6 to fix a security bug.
241 (CAN-2004-0398).
243 * Wed May 05 2004 David Summers <david@summersoft.fay.ar.us> 1.1.0-9628
244 - [!RHL7] Track changes to perl binding compile and install.
245 - Locale files now installed.
247 * Mon Apr 19 2004 Blair Zajac <blair@orcaware.com> 1.1.0-9438
248 - [RHL7, RHL8, RHL9] Require neon 0.24.5 to fix format string vulnerabilities
249 in XML/207 response handling. See
250 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0179
252 * Wed Mar 10 2004 David Summers <david@summersoft.fay.ar.us> 1.0.0-8983
253 - [RHEL3, RHEL4] Fedora-1 and WBEL-3 require db42-4.2.52 or greater.
255 * Tue Feb 24 2004 David Summers <david@summersoft.fay.ar.us> 1.0.0-8823
256 - [!RHL7] cvs2svn moved to separate project/package.
258 * Thu Feb 19 2004 David Summers <david@summersoft.fay.ar.us> 0.37.0-8770
259 - cvs2svn.1 man page taken out of distribution. Change RPM so that if it
260 just so happens to magically reappear someday then it will get put into
261 the package.
263 * Wed Jan 28 2004 David Summers <david@summersoft.fay.ar.us> 0.37.0-8534
264 - Change version number to new format based on dev list discussion.
266 * Sun Jan 18 2004 David Summers <david@summersoft.fay.ar.us> 0.36.0-8372
267 - Switched to the Redhat way of doing the "swig" package where it is not
268 separated into "swig" and "swig-runtime".
269 - Added subversion-perl package to support Perl (SWIG) bindings.
270 [RHL7] *** Note: Made it conditional as RedHat 7.x doesn't have the
271 required perl-5.8.0.
273 * Sat Jan 17 2004 David Summers <david@summersoft.fay.ar.us> 0.36.0-8362
274 - Now requires swig-1.3.19 so we can build the upcoming perl bindings.
276 * Sat Dec 27 2003 David Summers <david@summersoft.fay.ar.us> 0.35.1-8104
277 - [RHL7] Patch by Ben Reser <ben@reser.org> to get documentation to build
278 again.
279 - [RHL7] Updated to apache 2.0.48 (apr/apr-util 0.9.5).
280 - [RHL7] Added svnserve and svnserve.conf man pages.
282 * Thu Dec 25 2003 David Summers <david@summersoft.fay.ar.us> 0.35.1-8085
283 - [!RHL7] Patch by Ben Reser <ben@reser.org> to get documentation to build
284 again.
285 - [!RHL7] svnserve.conf and svnserve manual pages added.
287 * Fri Dec 19 2003 David Summers <david@summersoft.fay.ar.us> 0.35.0-8054
288 - Require httpd-2.0.48. *** Note: I don't yet have packages for httpd-2.0.48.
289 - [!RHL7] Require apr-0.9.5.
291 * Tue Oct 25 2003 Blair Zajac <blair@orcaware.com> 0.32.1-7520
292 - Require neon 0.24.4.
294 * Tue Oct 7 2003 Blair Zajac <blair@orcaware.com> 0.30.0-7342
295 - Require neon 0.24.3.
297 * Sat Jul 19 2003 David Summers <david@summersoft.fay.ar.us> 0.25.0-6515
298 - Added cvs2svn regression tests.
300 * Sat Jul 19 2003 David Summers <david@summersoft.fay.ar.us> 0.25.0-6514
301 - PORTING file no longer exists.
302 - Thanks to Ralph Loader <suckfish@ihug.co.nz> for the following changes:
303 - [!RHL7] Get rid of extraneous perl module dependencies via filter-requires.sh
304 script.
305 - gdbm-devel is not a build pre-req for subversion but APR/APR-UTIL.
306 - LDFLAGS no longer needed when compiling without subversion-devel installed.
307 - Use %configure instead of ./configure.
308 - expat is not a direct dependency of subversion.
309 - No need to copy separate subversion.conf and httpd.davcheck.conf as they
310 are in the source tree, just reference them there.
311 - Simplify "make install" by making use of DESTDIR macro instead of setting
312 individual directory components.
314 * Sun Jul 13 2003 David Summers <david@summersoft.fay.ar.us> 0.25.0-6462
315 - Fix revision number to be properly generated during RPM build. Can't use
316 the normal svnversion command at this point because the SRPM is not a
317 repository that we can get the version from via svnversion command.
319 * Sun Jul 13 2003 David Summers <david@summersoft.fay.ar.us> 0.25.0-6461
320 - Fix install/un-install not to bomb out on update if apache (httpd) doesn't
321 restart correctly.
323 * Thu Jul 10 2003 David Summers <david@summersoft.fay.ar.us> 0.25.0-6434
324 - Apache 2.0.47 now recommended because of security issues.
326 * Sat Jun 28 2003 David Summers <david@summersoft.fay.ar.us> 0.24.2-6365
327 - [!RHL7] RedHat decided to break out apr and apr-util separately from apache
328 (httpd package).
329 - [!RHL7] This also now builds on RedHat 9.0 because the new apr/apu-config
330 correctly picks up the openssl include files.
332 * Tue Jun 24 2003 David Summers <david@summersoft.fay.ar.us> 0.24.2-6334
333 - Now requires apache 2.0.46.
335 * Mon Jun 16 2003 David Summers <david@summersoft.fay.ar.us> 0.24.1-6256
336 - Added doxygen documentation.
338 * Tue Jun 10 2003 David Summers <david@summersoft.fay.ar.us> 0.23.0-6188
339 - Track changes for addition of mod_authz_svn httpd module.
341 * Sat Jun 07 2003 David Summers <david@summersoft.fay.ar.us> 0.23.0-6163
342 - svn-design.info is no longer built.
344 * Sat May 24 2003 David Summers <david@summersoft.fay.ar.us> 0.23.0-6036
345 - Track changes to Python SWIG build.
346 - Now requires neon-0.23.9 to pick up bug and security fixes.
347 - Now builds the book and puts it in /usr/share/doc/subversion-VERSION/book
348 directory. RedHat 7.x and RedHat 8.x users who build this RPM will need to
349 install or upgrade to the RedHat 9.0 docbook-style-xsl and libxslt packages.
351 * Thu May 15 2003 David Summers <david@summersoft.fay.ar.us> 0.22.2-5943
352 - The subversion package now requires python 2 because cvs2svn has been
353 unswigified and just depends on python 2.
354 - The new subversion-python package requires python 2.
356 * Sat May 10 2003 David Summers <david@summersoft.fay.ar.us> 0.22.1-5879
357 - svn-config has been taken back out of the distribution.
358 - cvs2svn no longer requires SWIG, so rename the subversion-cvs2svn package to
359 subversion-python and move the cvs2svn and RCS parser into the subversion
360 package.
361 - Added cvs2svn man page.
363 * Sun Apr 13 2003 David Summers <david@summersoft.fay.ar.us> 0.20.1-5610
364 - Added svndumpfilter.
366 * Fri Apr 04 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5549
367 - [!RHL7] Updated to Apache 2.0.45.
368 - [!RHL7] Took out libsvn_auth as it is no longer needed or used.
370 * Thu Apr 03 2003 David Summers <david@summersoft.fay.ar.us> 0.20.1-5542
371 - [RHL7] Updated to apache-2.0.45-0.1.
372 - [RHL7] Took out libsvn_auth as it is no longer generated or used.
374 * Sat Mar 01 2003 David Summers <david@summersoft.fay.ar.us> 0.18.1-5173
375 - Enabled RA_DAV checking.
376 Now requires httpd package to build because of RA_DAV tests.
378 * Sat Jan 18 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4433
379 - Created tools package to hold the tools.
381 * Thu Jan 16 2003 David Summers <david@summersoft.fay.ar.us> 0.16.1-4405
382 - Now requires Apache HTTPD >= 2.0.44-0.1 (APACHE_2_0_BRANCH) which contains
383 the new version of APR/APR-UTILS as of 2003.01.15.
384 - Added svnversion command.
386 * Tue Dec 31 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4218
387 - Create a svnadmin.static which is copied to svnadmin-version-release
388 when the package is erased, so users can still dump/load their repositories
389 even after they have upgraded the RPM package.
391 * Sun Dec 29 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4206
392 - [RHL7] Switched to new db4 package to be more like RedHat 8.0.
393 - [RHL7] Switched to new version of apache that combines APR and APRUTILS into
394 one package.
396 * Sat Dec 14 2002 David Summers <david@summersoft.fay.ar.us> 0.16.0-4128
397 - SWIG now builds so we can use cvs2svn.
399 * Fri Oct 04 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3280
400 - Made cvs2svn conditional (at least until we can get it to build consistently
401 and work).
403 * Sat Sep 21 2002 David Summers <david@summersoft.fay.ar.us> 0.14.3-3205
404 - Added SWIG dependencies to add cvs2svn capabilities.
406 * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2984
407 - Now requires neon-0.22.0.
409 * Thu Aug 15 2002 David Summers <david@summersoft.fay.ar.us> 0.14.1-2978
410 - Took out loading mod_dav_svn from subversion.spec file and put it in
411 subversion.conf file which goes into the apache conf directory.
412 - Simplify what gets put into httpd.conf to only the include for the
413 subversion.conf file.
414 (Thanks to Scott Harrison <sharrison@users.sourceforge.net> for prompting
415 me to do this).
417 * Thu Aug 08 2002 David Summers <david@summersoft.fay.ar.us> 0.14.0-2919
418 - Updated to APR/APR-UTIL 2002-08-08.
420 * Tue Jun 25 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2332
421 - Updated to APACHE/APR/APR-UTIL 2002-06-25.
422 - Previous version had a few problems because of missing apache error/ files.
424 * Sun Jun 23 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2318
425 - Updated to apache-2.0.40-0.3.
426 - Updated to subversion-0.13.1-2318.
428 * Tue Jun 18 2002 David Summers <david@summersoft.fay.ar.us> 0.13.0-2277
429 - Updated for RedHat 7.3 (autoconf253).
430 - Added a bunch of pre-requisites I didn't know were needed because I built a
431 new machine that didn't have them already installed.
432 - Fixed installation of man and info documentation pages.
434 * Wed Mar 06 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1447
435 - Back to apache-libapr* stuff, hopefully to stay.
437 * Sun Feb 24 2002 David Summers <david@summersoft.fay.ar.us> 0.9.0-1373
438 - Fixed expat.patch to not have to make so many changes by writing a small
439 shell script that changes libexpat to -lexpat.
441 * Fri Feb 22 2002 Blair Zajac <blair@orcaware.com> 0.9.0-1364
442 - Updated to neon-0.19.2.
444 * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1250
445 - Back to using apr and apr-util separately from apache.
447 * Mon Feb 11 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1232
448 - Updated to APR and APR-UTIL 2002.02.11.
449 - Updated to apache-2.0.32-0.2. (Requires apache-libapr and apache-libapr-util).
450 - Took out a (now non-existant) documentation file.
451 - Moved SPEC file changelog to after all package definitions.
453 * Sun Feb 03 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1153
454 - Updated to neon-0.18.5.
455 - Broke up apache and apache-devel into apache-apr, apache-apr-devel,
456 apache-apr-utils, and apache-apr-utils-devel.
457 - Updated apache to APR and APR-UTILS to 2002.02.03 version.
459 * Sat Feb 02 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1147
460 - Now builds without the separate APR package as it is built into and
461 "exported" from apache-2.0.31-0.3.
463 * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1132
464 - Took out patches to install procedure now not required because of fixes
465 in rev 1130.
467 * Fri Feb 01 2002 David Summers <david@summersoft.fay.ar.us> 0.8.0-1129
468 - Added requirement for APR 0.2002.01.19 rev 2 where the /usr/bin/apr-config
469 program was added.
471 * Sun Oct 28 2001 David Summers <david@summersoft.fay.ar.us>
472 - Release M5-r340: Added the subversion-server package.
474 * Fri Oct 26 2001 David Summers <david@summersoft.fay.ar.us>
475 - Release M5-r327: No longer need expat-lite. We can use the normal expat.
477 * Thu Sep 27 2001 David Summers <david@summersoft.fay.ar.us>
478 - Release M3-r117: Initial Version.
480 %define __perl_requires %{SOURCE3}
481 %define perl_sitearch %(eval "`perl -V:installsitearch`"; echo $installsitearch)
482 %define perl_version %(eval "`perl -V:version`"; echo $version)
484 %prep
485 %setup -q
487 # Patch for RPATH
488 %patch1 -p1
490 if [ -f /usr/bin/autoconf-2.53 ]; then
491 AUTOCONF="autoconf-2.53"
492 AUTOHEADER="autoheader-2.53"
493 export AUTOCONF AUTOHEADER
495 sh autogen.sh
497 # Delete apr, apr-util, and neon from the tree as those packages should already
498 # be installed.
499 rm -rf apr apr-util neon
501 %configure \
502 --disable-mod-activation \
503 --with-swig=%{_bindir}/swig \
504 --with-python=%{_bindir}/python%{pyver} \
505 --with-apxs=%{apache_dir}/sbin/apxs \
506 --with-apr=%{apache_dir}/bin/apr-config \
507 --with-apr-util=%{apache_dir}/bin/apu-config
509 %build
510 make clean
511 make
513 # Build python bindings
514 make swig-py
516 # Build PERL bindings
517 make swig-pl
518 make check-swig-pl
520 %if %{make_ra_local_bdb_check}
521 echo "*** Running regression tests on RA_LOCAL (FILE SYSTEM) layer ***"
522 make check CLEANUP=true FS_TYPE=bdb
523 echo "*** Finished regression tests on RA_LOCAL (FILE SYSTEM) layer ***"
524 %endif
526 %if %{make_ra_svn_bdb_check}
527 echo "*** Running regression tests on RA_SVN (SVN method) layer ***"
528 make svnserveautocheck CLEANUP=true FS_TYPE=bdb
529 echo "*** Finished regression tests on RA_SVN (SVN method) layer ***"
530 %endif
532 %if %{make_ra_dav_bdb_check}
533 echo "*** Running regression tests on RA_DAV (HTTP method) layer ***"
534 make davautocheck CLEANUP=true FS_TYPE=bdb
535 echo "*** Finished regression tests on RA_DAV (HTTP method) layer ***"
536 %endif
538 %if %{make_ra_local_fsfs_check}
539 echo "*** Running regression tests on RA_LOCAL (FILE SYSTEM) layer ***"
540 make check CLEANUP=true FS_TYPE=fsfs
541 echo "*** Finished regression tests on RA_LOCAL (FILE SYSTEM) layer ***"
542 %endif
544 %if %{make_ra_svn_fsfs_check}
545 echo "*** Running regression tests on RA_SVN (SVN method) layer ***"
546 make svnserveautocheck CLEANUP=true FS_TYPE=fsfs
547 echo "*** Finished regression tests on RA_SVN (SVN method) layer ***"
548 %endif
550 %if %{make_ra_dav_fsfs_check}
551 echo "*** Running regression tests on RA_DAV (HTTP method) layer ***"
552 make davautocheck CLEANUP=true FS_TYPE=fsfs
553 echo "*** Finished regression tests on RA_DAV (HTTP method) layer ***"
554 %endif
556 %install
557 rm -rf $RPM_BUILD_ROOT
558 mkdir -p $RPM_BUILD_ROOT/%{apache_dir}/conf
559 make install DESTDIR="$RPM_BUILD_ROOT"
561 # Add subversion.conf configuration file into httpd/conf.d directory.
562 mkdir -p $RPM_BUILD_ROOT/etc/httpd/conf.d
563 cp packages/rpm/redhat-8+/subversion.conf $RPM_BUILD_ROOT/etc/httpd/conf.d
565 # Install Python SWIG bindings.
566 make install-swig-py DESTDIR=$RPM_BUILD_ROOT DISTUTIL_PARAM=--prefix=$RPM_BUILD_ROOT
567 mkdir -p $RPM_BUILD_ROOT/%{_libdir}/python%{pyver}/site-packages
568 mv $RPM_BUILD_ROOT/%{_libdir}/svn-python/* $RPM_BUILD_ROOT/%{_libdir}/python%{pyver}/site-packages
569 rmdir $RPM_BUILD_ROOT/%{_libdir}/svn-python
571 # Install PERL SWIG bindings.
572 (cd subversion/bindings/swig/perl/native
573 perl Makefile.PL PREFIX=$RPM_BUILD_ROOT
575 make install-swig-pl DESTDIR=$RPM_BUILD_ROOT
577 # Clean up.
578 mkdir -p $RPM_BUILD_ROOT/%{_libdir}/perl5
579 mv $RPM_BUILD_ROOT/lib/perl5/site_perl $RPM_BUILD_ROOT/%{_libdir}/perl5
580 mv $RPM_BUILD_ROOT/share/man/man3 $RPM_BUILD_ROOT/usr/share/man
581 rm -rf $RPM_BUILD_ROOT/lib $RPM_BUILD_ROOT/share $RPM_BUILD_ROOT/%{_libdir}/perl5/site_perl/5.8.0/i386-linux-thread-multi/perllocal.pod
583 # Set up contrib and tools package files.
584 mkdir -p $RPM_BUILD_ROOT/%{_libdir}/subversion
585 cp -r tools $RPM_BUILD_ROOT/%{_libdir}/subversion
586 cp -r contrib $RPM_BUILD_ROOT/%{_libdir}/subversion
588 # Create doxygen documentation.
589 doxygen doc/doxygen.conf
591 %post server
592 # Restart apache server if needed.
593 source /etc/init.d/functions
594 if [ "`pidof httpd`"x != "x" ]; then
595 /etc/init.d/httpd restart || true
598 %postun server
599 # Restart apache server if needed.
600 source /etc/init.d/functions
601 if [ "`pidof httpd`"x != "x" ]; then
602 /etc/init.d/httpd restart || true
605 %clean
606 rm -rf $RPM_BUILD_ROOT
608 %files
609 %defattr(-,root,root)
610 %doc BUGS CHANGES COMMITTERS COPYING HACKING INSTALL README
611 %doc subversion/LICENSE
612 %{_bindir}/svn
613 %{_bindir}/svnadmin
614 %{_bindir}/svndumpfilter
615 %{_bindir}/svnlook
616 %{_bindir}/svnserve
617 %{_bindir}/svnsync
618 %{_bindir}/svnversion
619 %{_libdir}/libsvn_client*so*
620 %{_libdir}/libsvn_delta*so*
621 %{_libdir}/libsvn_diff*so*
622 %{_libdir}/libsvn_fs*so*
623 %{_libdir}/libsvn_ra*so*
624 %{_libdir}/libsvn_repos*so*
625 %{_libdir}/libsvn_subr*so*
626 %{_libdir}/libsvn_wc*so*
627 /usr/share/locale/*/*/*
628 /usr/share/man/man1/*
629 /usr/share/man/man5/*
630 /usr/share/man/man8/*
632 %files devel
633 %defattr(-,root,root)
634 %doc doc/doxygen/html/*
635 %{_libdir}/libsvn*.a
636 %{_libdir}/libsvn*.la
637 /usr/include/subversion-1
639 %files server
640 %defattr(-,root,root)
641 %config(noreplace) /etc/httpd/conf.d/subversion.conf
642 %{apache_dir}/lib/httpd/modules/mod_dav_svn.so
643 %{apache_dir}/lib/httpd/modules/mod_authz_svn.so
645 %files perl
646 %defattr(-,root,root)
647 %{perl_sitearch}/SVN
648 %{perl_sitearch}/auto/SVN
649 %{_libdir}/libsvn_swig_perl*so*
650 /usr/share/man/man3/SVN*
652 %files python
653 %defattr(-,root,root)
654 %{_libdir}/python%{pyver}/site-packages/svn
655 %{_libdir}/python%{pyver}/site-packages/libsvn
656 %{_libdir}/libsvn_swig_py*so*
658 %files tools
659 %defattr(-,root,root)
660 %{_libdir}/subversion/tools
661 %{_libdir}/subversion/contrib